<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Using scp Command in Linux: 10 Practical Examples Explained</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="rMSRiwTYGujwxoSuof32l6eh2Lugx8LGxfMvwX5q5VE" />
<meta name="dc.title" content="Using scp Command in Linux: 10 Practical Examples Explained" />
<meta name="dc.description" content="Here are some practical and essential scp command example to show how to securely copy files between remote Linux systems." />
<meta name="dc.relation" content="https://linuxhandbook.com/scp-command/" />
<meta name="dc.source" content="https://linuxhandbook.com/" />
<meta name="dc.language" content="en_US" />
<meta name="description" content="Here are some practical and essential scp command example to show how to securely copy files between remote Linux systems." />
<link rel="canonical" href="https://linuxhandbook.com/scp-command/" />
<script type="application/ld+json">{"@context" : "https://schema.org","@type" : "Organization","name" : "Linux Handbook","url" : "https:\/\/linuxhandbook.com"}</script>
<meta property="og:url" content="https://linuxhandbook.com/scp-command/" />
<meta property="og:site_name" content="Linux Handbook" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Using scp Command in Linux: 10 Practical Examples Explained" />
<meta property="og:description" content="Here are some practical and essential scp command example to show how to securely copy files between remote Linux systems." />
<meta property="og:image" content="https://linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Using scp Command in Linux: 10 Practical Examples Explained" />
<meta name="twitter:description" content="Here are some practical and essential scp command example to show how to securely copy files between remote Linux systems." />
<meta name="twitter:image" content="https://linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//a.optmnstr.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; Feed" href="https://linuxhandbook.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; Comments Feed" href="https://linuxhandbook.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; 10 Practical Examples of Using scp Command Comments Feed" href="https://linuxhandbook.com/scp-command/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='genesis-sample-css'  href='https://linuxhandbook.com/wp-content/themes/genesis-sample/style.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://linuxhandbook.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1543630994' type='text/css' media='all' />
<link rel='stylesheet' id='webui-popover-css'  href='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/vendor/webui-popover/jquery.webui-popover.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='lifterlms-styles-css'  href='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/css/lifterlms.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css'  href='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=1.7' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='ufwp_styles-css'  href='https://linuxhandbook.com/wp-content/plugins/wp-udemy/public/css/styles.min.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='ufwp_pro_styles-css'  href='https://linuxhandbook.com/wp-content/plugins/wp-udemy-pro/public/css/styles.min.css?ver=1.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-sample-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/4.9.8/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='https://linuxhandbook.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='tcm-front-styles-css-css'  href='https://linuxhandbook.com/wp-content/plugins/thrive-comments/assets/css/styles.css?ver=1.1.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-auth-check-css'  href='https://c0.wp.com/c/4.9.8/wp-includes/css/wp-auth-check.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/6.8/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/js/vendor/collapse.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/js/vendor/transition.js?ver=4.9.8'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=2.7.1'></script>
<script type='text/javascript'>
(adsbygoogle = window.adsbygoogle || []).push({google_ad_client: "ca-pub-6384374914382766", enable_page_level_ads: true, tag_partner: "genesis"});
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.optmnstr.com/app/js/api.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/thrive-comments/assets/js/libs-frontend.min.js?ver=1.1.13'></script>
<link rel='https://api.w.org/' href='https://linuxhandbook.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxhandbook.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxhandbook.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='cp Command in Linux: 7 Practical Examples' href='https://linuxhandbook.com/cp-command/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p9LuAS-fi' />
<style>

	/* for unique landing page accent color values,  put any new css added here inside tcb-bridge/js/editor */

	/* accent color */
	#thrive-comments .tcm-color-ac,
	#thrive-comments .tcm-color-ac span {
		color: #95b72d;
	}

	/* accent color background */
	#thrive-comments .tcm-background-color-ac,
	#thrive-comments .tcm-background-color-ac-h:hover span,
	#thrive-comments .tcm-background-color-ac-active:active {
		background-color: #95b72d	}

	/* accent color border */
	#thrive-comments .tcm-border-color-ac {
		border-color: #95b72d;
		outline: none;
	}

	#thrive-comments .tcm-border-color-ac-h:hover {
		border-color: #95b72d;
	}

	#thrive-comments .tcm-border-bottom-color-ac {
		border-bottom-color: #95b72d;
	}

	/* accent color fill*/
	#thrive-comments .tcm-svg-fill-ac {
		fill: #95b72d;
	}

	/* accent color for general elements */

	/* inputs */
	#thrive-comments textarea:focus,
	#thrive-comments input:focus {
		border-color: #95b72d;
		box-shadow: inset 0 0 3px #95b72d;
	}

	/* links */
	#thrive-comments a {
		color: #95b72d;
	}

	/*
	* buttons and login links
	* using id to override the default css border-bottom
	*/
	#thrive-comments button,
	#thrive-comments #tcm-login-up,
	#thrive-comments #tcm-login-down {
		color: #95b72d;
		border-color: #95b72d;
	}

	/* general buttons hover and active functionality */
	#thrive-comments button:hover,
	#thrive-comments button:active {
		background-color: #95b72d	}

</style>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-24863836-8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-24863836-8');
</script>

<script type="text/javascript" src="https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js" async="true"></script>
			<style type="text/css">
				html:not( .jetpack-lazy-images-js-enabled ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i2.wp.com/linuxhandbook.com/wp-content/uploads/2018/08/cropped-penguin-2.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/linuxhandbook.com/wp-content/uploads/2018/08/cropped-penguin-2.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/linuxhandbook.com/wp-content/uploads/2018/08/cropped-penguin-2.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/linuxhandbook.com/wp-content/uploads/2018/08/cropped-penguin-2.png?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				.entry-content code {
 background-color: #F2F2F2;
 padding: 0 .2em;
}
.entry-content pre {
 background-color: #F2F2F2;
 padding: .5em 1em;
 overflow: auto;
 word-wrap: normal;
}

/* Content Boxes
------------------------------------------------------------ */
 
.content-box-blue,
.content-box-gray,
.content-box-green,
.content-box-purple,
.content-box-red,
.content-box-black {
    margin: 0 0 25px;
    overflow: hidden;
    padding: 20px;
}
 
.content-box-blue {
	color: rgb(255, 255, 255);
  background-color: #0059b3;
}

.content-box-gray {
	color: rgb(000, 000, 000);
  background-color: #F2F2F2;
}

.content-box-green {
	color: rgb(255, 255, 255);
  background-color: #008758;
}

.content-box-purple {
	color: rgb(255, 255, 255);
  background-color: #cc4b00;
}

.content-box-red {
	color: rgb(255, 255, 255);
  background-color: #e02f36;
}

.content-box-black {
	color: rgb(255, 255, 255);
  background-color: #000000;
}			</style>
		</head>
<body class="post-template-default single single-post postid-948 single-format-standard header-full-width content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://linuxhandbook.com/">Linux Handbook</a></p><p class="site-description" itemprop="description">Linux Command Line, Server and Cloud</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-top" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87"><a href="https://linuxhandbook.com/76-2/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://linuxhandbook.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-91" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91"><a href="http://linuxhandbook.com/feed/" itemprop="url"><span itemprop="name">Feed</span></a></li>
<li id="menu-item-92" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-92"><a href="https://itsfoss.tradepub.com/category/information-technology-servers-and-linux-server-os/806/" itemprop="url"><span itemprop="name">Free Linux eBooks</span></a></li>
<li id="menu-item-93" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93"><a href="https://shop.itsfoss.com/" itemprop="url"><span itemprop="name">Shop</span></a></li>
</ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://linuxhandbook.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://linuxhandbook.com/category/linux-commands/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Linux Commands</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> 10 Practical Examples of Using scp Command</div><article class="post-948 post type-post status-publish format-standard category-linux-commands entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">10 Practical Examples of Using scp Command</h1>
<p class="entry-meta">Last Updated on <time class="entry-modified-time" itemprop="dateModified" datetime="2018-12-04T07:11:31+00:00">December 4, 2018</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://linuxhandbook.com/author/krishna/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Krishnaprasad</span></a></span> <span class="entry-comments-link"><a href="https://linuxhandbook.com/scp-command/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text">
<p><strong><em>Here are some practical and essential scp command example to show how to securely copy files between remote Linux systems.</em></strong></p>



<p style="text-align:left">You are probably already familiar with the <a href="https://linuxhandbook.com/cp-command/" target="_blank" rel="noreferrer noopener" aria-label="You are probably already familiar with the cp command in Linux which is used to copy files in Linux. cp command can be used only on the local machine.  (opens in a new tab)">cp command in Linux</a> which is used to copy files in Linux. cp command can be used only on the local machine. </p>



<p>But what about copying files from a remote Linux system? To copy files from a remote server or to a remote server, you can use a command called scp.</p>



<p class="has-background has-luminous-vivid-amber-background-color">Trivia: scp is short form for Secured Copy.</p>



<h2><span class="ez-toc-section" id="scp_command_syntax"><g class="gr_ gr_7 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="7" data-gr-id="7">scp</g> command syntax</span></h2>



<div class="wp-block-image"><figure class="aligncenter"><img data-attachment-id="1051" data-permalink="https://linuxhandbook.com/scp-command/scp-command-linux/" data-orig-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="scp-command-linux" data-image-description data-medium-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=702%2C395&amp;ssl=1" src="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?w=702&#038;ssl=1" alt="Laptop connected with server for coping files using scp command in Linux" class="wp-image-1051 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?w=800&amp;ssl=1 800w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?resize=768%2C432&amp;ssl=1 768w" data-lazy-sizes="(max-width: 702px) 100vw, 702px" data-lazy-src="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?w=702&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="1051" data-permalink="https://linuxhandbook.com/scp-command/scp-command-linux/" data-orig-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="scp-command-linux" data-image-description="" data-medium-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?fit=702%2C395&amp;ssl=1" src="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?w=702&#038;ssl=1" alt="Laptop connected with server for coping files using scp command in Linux" class="wp-image-1051" srcset="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?w=800&amp;ssl=1 800w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/scp-command-linux.jpeg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 702px) 100vw, 702px" data-recalc-dims="1" /></noscript></figure></div>



<p>The syntax and the usage of scp command is similar to the cp command and you&#8217;ll see it shortly in these scp command examples.</p>



<p>But first let&#8217;s take a look at the syntax of scp command:</p>



<pre class="wp-block-preformatted">scp &lt;options> source_path destination_path<br></pre>



<p>Depending on the origin of the file to be copied, the source can either be client or server. If the source is the client, then the destination is the server and vice-versa.<br></p>



<p>But that sounds too simple, isn&#8217;t it? The main focus of the scp command is n using the correct format for the source or destination path format.</p>



<p>A typical path to file or a directory on the server is represented in this format:<br></p>



<pre class="wp-block-preformatted">&lt;username>@&lt;ip_address_of_system>:&lt;path_to_the file/directory></pre>



<p>Actually, you can also use user@hostname in the scp command but it is more likely that you&#8217;ll end up with an error &#8220;<strong>Could not resolve hostname</strong>&#8220;.</p>



<p>This is because correlating the <a href="https://en.wikipedia.org/wiki/Hostname" target="_blank" rel="noreferrer noopener" aria-label="This is because correlating the hostname to the IP address is dependent on the network configuration of the server's network. Using the actual IP address saves you the trouble. (opens in a new tab)">hostname</a> to the IP address is dependent on the network configuration of the server&#8217;s network. Using the actual IP address saves you the trouble.</p>



<h3><span class="ez-toc-section" id="things_to_keep_in_mind_before_using_scp_command">Things to keep in mind before using scp command</span></h3>



<p>Here are a couple of things you need before you&#8217;ll be able to use the scp command on your Linux system:</p>



<ul><li>Make sure that <a rel="noreferrer noopener" aria-label="Make sure that ssh is installed and running on both client and server machines as scp command internally uses ssh. If ssh is not installed, install it by using the command &quot;sudo apt install ssh&quot;  on Debian based machines or using respective package managers of your distro. Whenever you use scp you will be prompted to enter the password of the remote host. Your file transfer will begin only when you enter the correct password of the remote host. (opens in a new tab)" href="https://www.ssh.com/ssh/protocol/" target="_blank">ssh</a> is installed and running on both client and server machines as <g class="gr_ gr_8 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="8" data-gr-id="8">scp</g> command internally uses ssh. If ssh is not installed, install it by using the command <em>&#8220;sudo apt install ssh&#8221; </em>on Debian based machines or using respective package managers of your distro.</li><li>You need to know the username and password of the remote system. You will be prompted to enter the password of the remote host. Your file transfer will begin <em>only</em> when you enter the correct password of the remote host.</li></ul>



<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://linuxhandbook.com/cp-command/" target="_blank" rel="nofollow" class="u2589a80858b0f2c64097426e21360aeb"><!-- INLINE RELATED POSTS 1/3 //--><style> .u2589a80858b0f2c64097426e21360aeb { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; text-decoration:none; } .u2589a80858b0f2c64097426e21360aeb:active, .u2589a80858b0f2c64097426e21360aeb:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u2589a80858b0f2c64097426e21360aeb { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u2589a80858b0f2c64097426e21360aeb .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u2589a80858b0f2c64097426e21360aeb .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u2589a80858b0f2c64097426e21360aeb:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ</span>&nbsp; <span class="postTitle">cp Command in Linux: 7 Practical Examples</span></div></a></div><h2><span class="ez-toc-section" id="using_scp_command_in_linux_10_practical_examples">Using <g class="gr_ gr_5 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="5" data-gr-id="5">scp</g> Command in Linux: 10 Practical Examples<br></span></h2>



<p>Now that we have seen the syntax of the <g class="gr_ gr_3 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="3" data-gr-id="3">scp</g> command and format to specify the path to the server, let us now see how to use the <g class="gr_ gr_17 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="17" data-gr-id="17">scp</g> command.<br></p>



<h3><span class="ez-toc-section" id="1_copying_a_file_to_the_remote_system_using_scp_command">1. Copying a file to the remote system using <g class="gr_ gr_11 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="11" data-gr-id="11">scp</g> command<br></span></h3>



<p>To copy a single file from local machine to remote host, specify the path to the file as source path and path in the remote host where the file has to be copied.<br></p>



<pre class="wp-block-preformatted">scp abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop<br></pre>



<h3 id="mce_54"><span class="ez-toc-section" id="2_copying_a_file_from_the_remote_system_using_scp_command">2. Copying a file from the remote system using <g class="gr_ gr_19 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="19" data-gr-id="19">scp</g> command</span></h3>



<p>Copying a file from remote system to the local system is pretty much the same. You just need to specify the complete path to the file on the remote system and path on the local system.</p>



<p>So to copy file from remote system to the current directory, simply use the command in the following fashion:</p>



<pre class="wp-block-preformatted">scp xyz@&lt;ip_address_of_xyz>:/remote/user/home/abc.txt .</pre>



<h3><span class="ez-toc-section" id="3_copying_multiple_files_using_scp_command">3. Copying multiple files using scp command<br></span></h3>



<p>To copy multiple files from the local machine to host, just specify the name of the files as the source path.<br></p>



<pre class="wp-block-preformatted">scp abc.txt def.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<h3><span class="ez-toc-section" id="4_copying_an_entire_directory_with_scp_command">4. Copying an entire directory with scp command<br></span></h3>



<p>To copy an entire folder, you can use the -r option and specify the name of the folder as the source path. This is called the recursive mode.<br></p>



<pre class="wp-block-preformatted">scp -r ~/Desktop/test xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<p>You can also specify more than one directory and copy them all in one single command.</p>



<h3><span class="ez-toc-section" id="5_see_the_file_transfer_details_in_the_output">5. See the file transfer details in the output<br></span></h3>



<p>If you are curious to know what happens behind the scenes while copying, you can use -v option to see all the processes that are executed including debugging, exit status, encryption, decryption etc. It&#8217;s called the verbose mode.</p>



<pre class="wp-block-preformatted">scp -v abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<h3><span class="ez-toc-section" id="6_copying_files_across_two_remote_hosts">6. Copying files across two remote hosts<br></span></h3>



<p>So far, you have seen how to copy from local machine to a remote machine. <br>To copy files from one remote computer to another remote computer, specify the paths of both source and destination in remote computer&#8217;s format as discussed above.</p>



<pre class="wp-block-preformatted">scp abc@&lt;ip_address_of_abc>:&lt;path_of_file_or_folder> xyz@&lt;ip_address_of_xyz>:&lt;path_of_file_or_folder</pre>



<p>Needless to say that you need to know password of both the systems here.</p>



<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://linuxhandbook.com/cd-command-examples/" target="_blank" rel="nofollow" class="u817ec30337c659d3a5adb9eb1d5cd80b"><!-- INLINE RELATED POSTS 2/3 //--><style> .u817ec30337c659d3a5adb9eb1d5cd80b { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; text-decoration:none; } .u817ec30337c659d3a5adb9eb1d5cd80b:active, .u817ec30337c659d3a5adb9eb1d5cd80b:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u817ec30337c659d3a5adb9eb1d5cd80b { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u817ec30337c659d3a5adb9eb1d5cd80b .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u817ec30337c659d3a5adb9eb1d5cd80b .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u817ec30337c659d3a5adb9eb1d5cd80b:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ</span>&nbsp; <span class="postTitle">7 Practical Examples of cd Command in Linux</span></div></a></div><h3><span class="ez-toc-section" id="7_copying_files_with_compression_reduces_transfer_time">7. Copying files with compression [reduces transfer time]</span></h3>



<p>If you try to copy a bunch of files together, it will take more time than the transfer of a single file of the size equivalent to the sum of all the individual files.</p>



<p>If you feel that you need to increase the speed of transferring files, you can compress the files by using -C option and transfer the files.</p>



<p>The best thing is that the compression happens only while transferring. Once the transfer is completed, the files will be stored in their original form. You won&#8217;t see an <g class="gr_ gr_59 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="59" data-gr-id="59">arhcive</g> file but all the individual files as they were on the remote server.</p>



<pre class="wp-block-preformatted">scp -C abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<h3><span class="ez-toc-section" id="8_limiting_the_bandwidth_of_file_transfer">8. Limiting the bandwidth of file transfer<br></span></h3>



<p>If you feel that transfer of files is utilizing most of the bandwidth, you can reduce the bandwidth of file transfer using -l option followed by the new bandwidth rate.<br></p>



<pre class="wp-block-preformatted">scp -l 800 abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<p>Note that the bandwidth you specify in the command is in kilobits per sec but while transferring the files, the <g class="gr_ gr_4 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="4" data-gr-id="4">scp</g> command output will show the transfer rate in kilobytes per second. </p>



<p>Since 1 byte=8 <g class="gr_ gr_3 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" id="3" data-gr-id="3">bits</g>, the8300 kilobits per second in the command parameter becomes 100 kilobytes per <g class="gr_ gr_33 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="33" data-gr-id="33">soond</g> in the command output.</p>



<h3><span class="ez-toc-section" id="9_preserving_the_original_attributes_of_the_copied_files">9. Preserving the original attributes of the copied files<br></span></h3>



<p>If you need to preserve the original file attributes such as the <a rel="noreferrer noopener" href="https://linuxhandbook.com/linux-file-permissions/">file permissions and ownership</a>, <a rel="noreferrer noopener" href="https://linuxhandbook.com/file-timestamps/">file timestamps</a>, etc., use -p option.<br></p>



<pre class="wp-block-preformatted">scp -p abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<h3><span class="ez-toc-section" id="10_hiding_the_output_of_scp_command">10. Hiding the output of scp command<br></span></h3>



<p>If you are not comfortable with the lengthy output of <g class="gr_ gr_4 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="4" data-gr-id="4">scp</g> command, you can avoid the output of the command by using -q option. This is called the quite mode.</p>



<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://linuxhandbook.com/csplit-command/" target="_blank" rel="nofollow" class="uc4f384e379b14340eaa3df5dda44ba57"><!-- INLINE RELATED POSTS 3/3 //--><style> .uc4f384e379b14340eaa3df5dda44ba57 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; text-decoration:none; } .uc4f384e379b14340eaa3df5dda44ba57:active, .uc4f384e379b14340eaa3df5dda44ba57:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .uc4f384e379b14340eaa3df5dda44ba57 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .uc4f384e379b14340eaa3df5dda44ba57 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .uc4f384e379b14340eaa3df5dda44ba57 .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .uc4f384e379b14340eaa3df5dda44ba57:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ</span>&nbsp; <span class="postTitle">csplit: A Better Way to Split File in Linux Based on its Content</span></div></a></div><p>It even hides the progress of copying files.<br></p>



<pre class="wp-block-preformatted">scp -q abc.txt xyz@&lt;ip_address_of_xyz>:/home/xyz/Desktop</pre>



<p><em>In the above examples, you have seen how to copy the files to the remote host from the local machine. If you need to copy files from remote host to the local machine, write the path of the file/folder to be copied from the remote host as source path and the path where the file/folder has to be pasted in the local machine as destination path.</em><br></p>



<p>Fore more detail on the scp command, please refer to <a href="https://linux.die.net/man/1/scp" target="_blank" rel="noreferrer noopener" aria-label="Fore more detail on the scp command, please refer to its man page. (opens in a new tab)">its man page</a>.</p>



<p>I hope that you now have understood how to make the <g class="gr_ gr_7 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" id="7" data-gr-id="7">best</g> use of <g class="gr_ gr_6 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="6" data-gr-id="6">scp</g> command to securely copy files between computers.</p>



<p>If you come across any issues feel free to ask questions in the comment section below. And if you know any other awesome <g class="gr_ gr_36 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" id="36" data-gr-id="36">scp</g> command tip, do share it with the rest of <g class="gr_ gr_103 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-del replaceWithoutSep" id="103" data-gr-id="103">the us</g> here.</p>
<span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><span class="ez-toc-section" id="related"><em>Related</em></span></h3>
</div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://linuxhandbook.com/category/linux-commands/" rel="category tag">Linux Commands</a></span> </p></footer></article><div class="after-entry widget-area"><section id="media_image-3" class="widget widget_media_image"><div class="widget-wrap"><a href="https://shareasale.com/r.cfm?b=1280559&#038;u=747593&#038;m=59485&#038;urllink=&#038;afftrack="><img width="729" height="91" src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?fit=729%2C91&amp;ssl=1" class="image wp-image-1008  attachment-full size-full jetpack-lazy-image" alt="Linux Foundation Cyber Monday Discount Sale" style="max-width: 100%; height: auto;" data-attachment-id="1008" data-permalink="https://linuxhandbook.com/linux-foundation-cyber-monday-2/" data-orig-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?fit=729%2C91&amp;ssl=1" data-orig-size="729,91" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Linux-Foundation-Cyber-Monday-2" data-image-description="" data-medium-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?fit=300%2C37&amp;ssl=1" data-large-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?fit=702%2C88&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?w=729&amp;ssl=1 729w, https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?resize=300%2C37&amp;ssl=1 300w" data-lazy-sizes="(max-width: 729px) 100vw, 729px" data-lazy-src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/Linux-Foundation-Cyber-Monday-2.png?fit=729%2C91&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
</div><div id="comments">
	<div id="thrive-comments" class="clearfix">
		<div class="tcm-dot-loader">
			<span class="inner1"></span>
			<span class="inner2"></span>
			<span class="inner3"></span>
		</div>
		<div class="thrive-comments-content">
			<div class="tcm-comments-filter"></div>
			<div class="tcm-comments-create"></div>
			<div class="tcm-comments-list">
							</div>
			<div class="tcm-lazy-comments"></div>
		</div>
	</div>
</div>
</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-2" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://linuxhandbook.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-5c067f4c5be749.94941885" placeholder="Search this website &#x2026;"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://linuxhandbook.com/?s={s}"></form></div></section>
<section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><h3 class="widgettitle widget-title">Follow 40,000+ Strong Linux Community</h3>
<ul class="alignleft"><li class="ssi-facebook"><a href="https://www.facebook.com/LinuxHandbook" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-facebook" aria-labelledby="social-facebook-2"><title id="social-facebook-2">Facebook</title><use xlink:href="https://linuxhandbook.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-rss"><a href="https://linux.die.net/man/1/chgrp" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-2"><title id="social-rss-2">RSS</title><use xlink:href="https://linuxhandbook.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/linuxhandbook" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-2"><title id="social-twitter-2">Twitter</title><use xlink:href="https://linuxhandbook.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="ezw_tco-2" class="widget ez-toc"><div class="widget-wrap"><div class="ez-toc-widget-container counter-flat ez-toc-affix">

					<h3 class="widgettitle widget-title">
					<span class="ez-toc-title-container">

						<style type="text/css">
							#ezw_tco-2 .ez-toc-widget-container ul.ez-toc-list li.active::before {
								background-color: #ededed;
							}
						</style>

						<span class="ez-toc-title">Contents</span>

						<span class="ez-toc-title-toggle">

							<a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a>
						</span>

					</span>

					</h3>

					<nav><ul class="ez-toc-list">
<li><a href="#scp_command_syntax">scp command syntax</a></li><li><a href="#things_to_keep_in_mind_before_using_scp_command">Things to keep in mind before using scp command</a></li><li><a href="#using_scp_command_in_linux_10_practical_examples">Using scp Command in Linux: 10 Practical Examples</a></li><li><a href="#1_copying_a_file_to_the_remote_system_using_scp_command">1. Copying a file to the remote system using scp command</a></li><li><a href="#2_copying_a_file_from_the_remote_system_using_scp_command">2. Copying a file from the remote system using scp command</a></li><li><a href="#3_copying_multiple_files_using_scp_command">3. Copying multiple files using scp command</a></li><li><a href="#4_copying_an_entire_directory_with_scp_command">4. Copying an entire directory with scp command</a></li><li><a href="#5_see_the_file_transfer_details_in_the_output">5. See the file transfer details in the output</a></li><li><a href="#6_copying_files_across_two_remote_hosts">6. Copying files across two remote hosts</a></li><li><a href="#7_copying_files_with_compression_reduces_transfer_time">7. Copying files with compression [reduces transfer time]</a></li><li><a href="#8_limiting_the_bandwidth_of_file_transfer">8. Limiting the bandwidth of file transfer</a></li><li><a href="#9_preserving_the_original_attributes_of_the_copied_files">9. Preserving the original attributes of the copied files</a></li><li><a href="#10_hiding_the_output_of_scp_command">10. Hiding the output of scp command</a></li><li><a href="#related">Related</a></li></ul></nav>
</div>
</div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 chmod777 · Built On <a href="https://shareasale.com/r.cfm?b=242694&#038;u=747593&#038;m=28169&#038;urllink=&#038;afftrack=">Genesis Framework</a> · <a href="https://wordpress.org/">WordPress</a> · <a href="https://linuxhandbook.com/wp-login.php">Log in</a></p></div></footer></div><script type="text/template" id="comments-conversion"><# if ( html_switch === 'tcm_live_update' ) { #>
	<div class="tcm-thank-you-submited tcm-border-color-ac">
		<#= custom_message #>
	</div>
<# } #>
<# if ( html_switch === 'tcm_related_posts' ) { #>
	<div class="tcm-posts tcm-border-color-ac">
	        <#= custom_message #>
	        <div class="tcm-posts-list <# if ( ! show_featured_image ) { #> no-featured-image <# } #> clear-this posts-length-<#= ThriveComments.related_posts.length #>">
		        <# ThriveComments.related_posts.forEach( function ( value ) { #>
			        <div class="tcm-post tcm-color-ac <# if ( ! show_featured_image ) { #> tcm-border-bottom-color-ac <# } #>">
				        <# if ( show_featured_image ) { #>
				            <div>
		                         <a href="<#= value.guid #>" style="background-image: url(<#= value.featured_image #>)" class="tcm-related-thumbnail <# if ( ! value.featured_image ) { #>tcm-no-featured-image<# } #>">
	                            </a>
				            </div>
					    <# } #>
				        <h3><a href="<#= value.guid #>">

								<span>
									<svg class="related-posts-arrow tcm-svg-fill-ac"><use xlink:href="#tcm-related-posts-arrow"></use></svg>								</span>


								<#= value.post_title #>

								</#></a></h3>
			        </div>
		        <# } ) #>
	        </div>
	</div>
<# } #>
<# if ( html_switch === 'tcm_social_share' ) { #>
	<div class="tcm-share-post tcm-border-color-ac">
		<#= custom_message #>
		<div class="share-buttons">
			<# if ( share_btns.fb_share ) { #><div class="fb-button" data-href="http://www.facebook.com/share.php"></div><# } #>
			<# if ( share_btns.tw_share ) { #><div class="tw-button" data-href="https://twitter.com/intent/tweet"></div><# } #>
			<# if ( share_btns.lk_share ) { #><div class="in-button" data-href="https://www.linkedin.com/cws/share"></div><# } #>
			<# if ( share_btns.pt_share ) { #><div class="pt-button" data-href="http://pinterest.com/pin/create/button"></div><# } #>
			<# if ( share_btns.gg_share ) { #><div class="gm-button" data-href="https://plus.google.com/share"></div><# } #>
			<# if ( share_btns.xi_share ) { #><div class="xi-button" data-href="https://www.xing.com/spi/shares/new"></div><# } #>
		</div>
	</div>
<# } #>
</script><script type="text/template" id="comments-create">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</script><script type="text/template" id="comments-deleted"><div class="tcm-deleted-comment clear-this">
	<div class="deleted-header">
		<div class="moderation-img no-image" data-social-avatar="<#= comment.get('social_avatar') #>" data-email="<#= comment.get('comment_author_email') #>" data-src="<#= comment.get('photo_src') #>" style="background-image: url(<#= comment.get('author_avatar_urls') #>);"></div>
		<div class="deleted-header-text">
			<strong>
				<#= comment.get('author_name') #>
			</strong>
			<span>
				<#= comment.get('formatted_date') #>
			</span>
		</div>
	</div>
	<div class="deleted-text">
		<p class="deleted-info-text tcm-color-ac">
			<# if ( comment.get('status') === 'spam' ) { #>
			<span>This comment was marked as spam</span>
			<# } else { #>
			<span>This comment was marked as trash</span>
			<# } #>
			<a href="#" data-key="z" class="undo-action">Undo</a>
		</p>

		<p>
			<#= comment.get('comment_content') #>
		</p>
	</div>
</div>
</script><script type="text/template" id="comments-item">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</script><script type="text/template" id="comments-lazy-loading"><button class="tcm-loader">
	<div style="display: inline-block" class="tcm-dot-loader done">
		<span class="inner1"></span>
		<span class="inner2"></span>
		<span class="inner3"></span>
	</div>
	<p>
		<#= ThriveComments.util.render_label('load_comments') #>
	</p>
</button>
<# if ( comments_rendered > 2 && ! ThriveComments.close_comments ) { #>
<div class="add-comment tcm-background-color-ac">
	<p>
			<span class="add-comment-icon">
				<svg class="add-comment-svg"><use xlink:href="#tcm-add-comment"></use></svg>			</span>
		<#= ThriveComments.util.render_label('add_comment') #></#></p>
</div>
<# } #>
<# if ( showPoweredBy ) { #>
<div class="tcm-powered-by">
    	<a href="https://thrivethemes.com/comments/" title="Powered by Thrive Comments" target="_blank">
			<span class="tcm-footer-logo">
				<svg class="logo-footer-svg"><use xlink:href="#tcm-logo-footer"></use></svg>			</span>

		<span>
			Powered by 		</span>
		<span>
			Thrive Comments		</span>
	</a>
</div>
<# } #>

<# if ( ! ThriveComments.close_comments && ThriveComments.email_services.length !== 0 ) { #>
	<div class="tcm-align-right">

		<a href="javascript:void(0)" class="tcm-link-unsubscribe" title="<#= ThriveComments.util.render_label('unsubscribe') #>"
		<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) || ( typeof ThriveComments.current_user.ID === 'undefined' ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('unsubscribe') #></a>

		<a href="javascript:void(0)" class="tcm-link-subscribe" title="<#= ThriveComments.util.render_label('subscribe') #>"
		<# if ( - 1 !== ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('subscribe') #></a>

		<div id="tcm-subscribe-form" class="tcm-subscribe-form" hidden>
			<div class="tcm-error-message"></div>
			<input class="form-input tcm-subscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
			<button class="submit-subscribe-post"><#= ThriveComments.util.render_label('subscribe') #></a></button>
		</div>

		<# if ( typeof ThriveComments.current_user.ID === 'undefined' ) { #>
			<div id="tcm-unsubscribe-form" class="tcm-subscribe-form"
			<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID )  ) { #> hidden <# } #> >
				<div class="tcm-error-message"></div>
				<input class="form-input tcm-unsubscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
				<button class="submit-unsubscribe-post"><#= ThriveComments.util.render_label('unsubscribe') #></a></button>
			</div>
		<# } #>
        <p class="tcm-already-subscribed" hidden> Already subscribed! </p>

    </div>
<# } #>
<div class="clear"></div>
</script><script type="text/template" id="comments-list"><div id="tcm-comments-filter" class="tcm-comments-filter">
	<div class="tcm-lazy-loader"></div>
</div></script><script type="text/template" id="comments-moderation"><div class="tcm-moderate-dots tcm-background-color-ac-h">
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
</div>

<div class="tcm-dropdown-moderate">
	<# _.each( actions, function( action, key ){ #>
	<div class="tcm-dropdown-moderate-element" data-fn="<#= action.fn #>" data-value="<#= action.value #>"><#= action.text #></div>
	<# }) #>
</div></script><script type="text/template" id="comments-sort"><div class="tcm-comments-filters">
	<div class="left">
		<div class="tcm-comments-number">
			<#= ThriveComments.util.render_label( 'number_of_comments', 'comment_count' ) #>
		</div>
	</div>
	<div class="right">
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','before') #>
		</label>
		<div name="sort-by" id="tcm-sort-by" class="tcm-dropdown tcm-filter-dropdown tcm-really-random">
            <span class="tcm-toggle-button current-sorting">
                <# if ( ThriveComments.settings.comment_order === 'desc') { #>
					<#= ThriveComments.util.render_label( 'newest') #>
					<# } else if( ThriveComments.settings.comment_order === 'asc') { #>
					<#= ThriveComments.util.render_label( 'oldest') #>
					<# } else {#>
				<# if( ThriveComments.settings.tcm_vote_type != 'no_vote' ) {#>
					<#= ThriveComments.util.render_label( 'top_rated') #>
					<# } #>
				<# } #>
			</span>

			<span class="dropdown-arrow-comments">
						<svg class="sort-by-dropdown-svg"><use xlink:href="#tcm-sort-by-dropdown"></use></svg>			</span>

			<div class="tcm-dropdown-content">

				<div data-value="desc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'newest') #>
				</div>
				<div data-value="asc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'oldest') #>
				</div>
				<# if(ThriveComments.settings.tcm_vote_type != 'no_vote'){#>
				<div data-value="top-rated" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'top_rated') #>
				</div>

				<# } #>

			</div>
		</div>
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','after') #>
		</label>
	</div>
</div>
<div class="clear"></div>
<# if ( ThriveComments.close_comments ) { #>
<div class="tcm-closed-comments" style="text-align: center">
	<p>
		<#= ThriveComments.util.render_label('close_comments') #>
	</p>
</div>
<# } #></script>	<div id="wp-auth-check-wrap" class="hidden">
	<div id="wp-auth-check-bg"></div>
	<div id="wp-auth-check">
	<button type="button" class="wp-auth-check-close button-link"><span class="screen-reader-text">Close dialog</span></button>
			<div id="wp-auth-check-form" class="loading" data-src="https://linuxhandbook.com/wp-login.php?interim-login=1&#038;wp_lang=en_US"></div>
			<div class="wp-auth-fallback">
		<p><b class="wp-auth-fallback-expired" tabindex="0">Session expired</b></p>
		<p><a href="https://linuxhandbook.com/wp-login.php" target="_blank">Please log in again.</a>
		The login page will open in a new window. After logging in you can close it and return to this page.</p>
	</div>
	</div>
	</div>
	<div style="display: none;">
    <svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"xml:space="preserve">
	<defs>

	<symbol id="tcm-reply" viewBox="0 0 100 100">
			<g>
				<path d="M69.9,38.1L69.9,38.1c-1.5-3.7-4.7-6.4-7.4-9.2c-2.8-2.8-6.3-4.7-9.9-6.3c-3.7-1.6-7.7-2.4-11.7-2.4h-11
					l4.7-4.8c3.4-3.4,3.4-9,0-12.4c-3.4-3.4-8.9-3.4-12.2,0L2.8,22.7c-3.4,3.4-3.4,9,0,12.4l19.4,19.7c1.7,1.7,3.9,2.6,6.1,2.6
					c2.2,0,4.4-0.9,6.1-2.6c3.4-3.4,3.4-9,0-12.4l-4.6-4.6h10.9c3.4,0,6.6,1.4,9.1,3.8l4.8,4.8c1.2,2,3,3.4,5.1,4.1
					c2.1,0.6,4.5,0.4,6.6-0.7C70.5,47.5,72,42.3,69.9,38.1z"/>
				<ellipse cx="81.1" cy="60.8" rx="8.5" ry="8.6"/>
			</g>
	</symbol>

	<symbol id="tcm-icon-thumb_down" viewBox="0 0 24 24">
		<g>
			<path d="M18.984 3h4.031v12h-4.031v-12zM15 3c1.078 0 2.016 0.938 2.016 2.016v9.984c0 0.563-0.234 1.031-0.609
			1.406l-6.563 6.609-1.078-1.078c-0.281-0.281-0.422-0.609-0.422-1.031v-0.328l0.984-4.594h-6.328c-1.078 0-2.016-0.891-2.016-1.969l0.047-0.094h-0.047v-1.922c0-0.281
			0.047-0.516 0.141-0.75l3.047-7.031c0.281-0.703 0.984-1.219 1.828-1.219h9z" />
		</g>
	</symbol>

	<symbol id="tcm-icon-thumb_up" viewBox="0 0 24 24">
		<g>
			<path d="M23.016 9.984l-0.047 0.094h0.047v1.922c0 0.281-0.047 0.516-0.141 0.75l-3.047 7.031c-0.281 0.703-0.984
			1.219-1.828 1.219h-9c-1.078 0-2.016-0.938-2.016-2.016v-9.984c0-0.563 0.234-1.031 0.609-1.406l6.563-6.609 1.078
			1.078c0.281 0.281 0.422 0.609 0.422 1.031v0.328l-0.984 4.594h6.328c1.078 0 2.016 0.891 2.016 1.969zM0.984 21v-12h4.031v12h-4.031z" />
		</g>>

	</symbol>

	<symbol id="tcm-add-comment" viewBox="0 0 267.3 245">
		<path style="fill:#FFFFFF;" class="st0" d="M265.7,61C259.6,27.5,230.3,2,195.1,2H72.5C33,2,0.8,34.2,0.8,73.8v77c0,0.1,0,0.1,0,0.2v81.6
			c0,0-1.8,11.1,9.7,11.1c0,0,4.2,1,13.1-4.6l46.8-43.2h124.6c39.5,0,71.7-32.2,71.7-71.7V83.8L265.7,61z M78.4,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6S93,91.4,93,99.5C93,107.5,86.5,114,78.4,114z M137.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C152.1,107.5,145.5,114,137.5,114z M196.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C211.1,107.5,204.6,114,196.5,114z"/>
	</symbol>

	<symbol id="tcm-logo-footer" viewBox="0 0 130 100">
		<path style="fill:#434343;" class="st0" d="M108.8,26.5C106.7,14.9,96.5,6.1,84.4,6.1H41.9C28.2,6.1,17,17.2,17,30.9v26.7c0,0,0,0,0,0.1v28.2
			c0,0-0.6,3.8,3.4,3.8c0,0,1.5,0.4,4.6-1.6l16.2-14.9h12.1c0.1-0.2,0.3-0.4,0.4-0.6l2.2-3.1c0.4-0.6,1.9-2.3,3.1-3.6H37.6
			c-1.1,0-2.1,0.6-2.8,1.4l0,0L24.1,78.6V58.2c0-0.2,0.1-0.4,0.1-0.6V30.9c0-9.7,7.9-17.6,17.6-17.6h42.5c9.7,0,17.6,7.9,17.6,17.6
			v16.9c2.6-0.4,5.3-0.6,7.2-0.7V34.4L108.8,26.5z"/>
		<path style="fill:#57A245;" class="st1" d="M43.7,39.9c-3.3,0-6-2.7-6-6c0-3.3,2.7-6,6-6h38.9c3.3,0,6,2.7,6,6c0,3.3-2.7,6-6,6H43.7z"/>
		<path style="fill:#434343;" class="st0" d="M43.7,52.2h38.9c2.4,0,4.3-1.9,4.3-4.3s-1.9-4.3-4.3-4.3H43.7c-2.4,0-4.3,1.9-4.3,4.3S41.3,52.2,43.7,52.2"/>
		<path style="fill-rule:evenodd;clip-rule:evenodd;fill:#57A245;" class="st2" d="M118.2,52.4c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4
			c-3.4,4.2-4.1,4.9-6.8,10.2c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5
			c-0.6,0.5-1.3,1-1.9,1.5c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2
			c-0.2,0.1-0.4,0.2-0.5,0.2c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7
			c0.6-1.4,1.3-2.8,2.1-4.1c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6l0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7l4.1-1.9
			c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3
			c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4
			c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6
			c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8
			c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9
			c3.5-0.7,12.3-2.3,16.6-2.3h0.9C114,51.2,117.4,51.2,118.2,52.4z"/>
		<path style="fill:none;" class="st3" d="M99.5,58.5c0.4,0,0.2,0,0.2-0.1C99.4,58.4,99.6,58.4,99.5,58.5z M99.5,58.5c0.1-0.1-0.1-0.1,0.2-0.1
			C99.7,58.5,99.9,58.5,99.5,58.5 M99.9,58.3l-0.1,0.1 M99.5,58.5c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3
			c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3
			c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5
			c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3
			c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8
			c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9c3.5-0.7,12.3-2.3,16.6-2.3h0h0.2h0.6c2.2,0,5.6,0.1,6.4,1.3
			c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4c-3.4,4.2-4.1,4.9-6.8,10.2
			c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5c-0.6,0.5-1.3,1-1.9,1.5
			c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2c-0.2,0.1-0.4,0.2-0.5,0.2
			c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7c0.6-1.4,1.3-2.8,2.1-4.1
			c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6c0.1-0.1,0.2-0.2,0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7L99.5,58.5"/>
	</symbol>

	<symbol id="tcm-related-posts-arrow" viewBox="0 0 16 16">
		<path class="st0" d="M8,15.9c-4.4,0-7.9-3.5-7.9-7.9S3.6,0.1,8,0.1s7.9,3.5,7.9,7.9S12.4,15.9,8,15.9z M8,2.4C4.9,2.4,2.4,4.9,2.4,8
			s2.5,5.6,5.6,5.6s5.6-2.5,5.6-5.6S11.1,2.4,8,2.4z M11.9,8.3l-3.3,3.3c-0.1,0.1-0.2,0.1-0.2,0.1c-0.2,0-0.3-0.2-0.3-0.3v-2H4.4
			C4.2,9.3,4.1,9.2,4.1,9V7c0-0.2,0.2-0.3,0.3-0.3H8v-2c0-0.2,0.1-0.3,0.3-0.3c0.1,0,0.2,0,0.2,0.1l3.3,3.3C11.9,7.9,12,7.9,12,8
			S11.9,8.2,11.9,8.3z"/>
	</symbol>

	<symbol id="tcm-sort-by-dropdown" viewBox="0 0 12 7">
		<path style="fill:#6E767D;" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z"/>
	</symbol>

	<symbol id="tcm-author-icon" viewBox="0 0 1020 1080">
		<polygon style="fill:#474F57" class="st0" points="44.5,882.9 251.4,1081 251.4,889.8 "/>
		<path style="fill:#6E767D" class="st1" d="M937.8,891.8H81.2c-44.3,0-80.6-36.3-80.6-80.6V82.7c0-44.3,36.3-80.6,80.6-80.6h856.6
			c44.3,0,80.6,36.3,80.6,80.6v728.5C1018.4,855.5,982.1,891.8,937.8,891.8z"/>
		<g>
			<path style="fill:#6E767D" class="st2" d="M732,688.3c-0.5,0.1-2.7,0.5-6.3,1.1c-142.4,25.4-168.6,29.8-171.6,30.1c-7,0.8-12.3,0.4-16-1.3
				c-2.4-1-3.6-2.3-4-2.8c0.2-1,1.4-3.3,2.2-4.7c0.7-1.4,1.6-3,2.3-4.6c4.9-11.1,1.5-22.4-8.9-29.5c-7.8-5.3-18.1-7.4-30.6-6.3
				c-7.5,0.6-138.9,22.6-211.1,34.7l-35.4,27.7c82.6-13.9,240.1-40.2,248.4-41c7.4-0.6,13.2,0.3,16.7,2.7c2,1.4,1.8,1.8,1.3,3.1
				c-0.4,0.9-1,2-1.6,3.2c-2.4,4.4-5.6,10.5-4.5,18c1.2,8.2,7.3,15.3,16.7,19.4c5.3,2.3,11.4,3.5,18.4,3.5c2.8,0,5.7-0.2,8.8-0.5
				c5.7-0.7,63.8-10.9,172.9-30.3c3.6-0.6,5.8-1,6.3-1.1c5.9-1,9.8-6.6,8.7-12.5C743.4,691.2,737.8,687.3,732,688.3L732,688.3z
				 M732,688.3"/>
			<path style="fill:#FFFFFF" class="st2" d="M349.8,583.9l-91.7,95.5c-10.1,10.5-17.2,23.5-20.6,37.7l130.2-102c40.8,18,73.3,23.7,98.3,23.7
				c43.8,0,64.2-17.7,64.2-17.7c-40.8-21.2-46.6-60.6-46.6-60.6c31.3,13.2,96.4,28.7,96.4,28.7c86.5-57.5,131.7-181.9,131.7-181.9
				c-9,2.5-17.5,3.5-25.6,3.5c-40.6,0-68.5-25.9-68.5-25.9l113-24.5c37.6-76.7,41.2-211.1,41.2-211.1L428.2,453.5
				C389.2,487.9,361.9,533.4,349.8,583.9L349.8,583.9z M349.8,583.9"/>
		</g>
	</symbol>

	<symbol id="tcm-bulk-action-arrow" viewBox="0 0 12 7">
		<path style="fill:#6E767D" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z"/>
	</symbol>


	</defs>
	</svg>
</div><style type="text/css" media="screen"> #simple-social-icons-2 ul li a, #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #000000 !important; border-radius: 3px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 20px; padding: 10px; }  #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #f5f5f5 !important; border-color: #ffffff !important; color: #000000 !important; }  #simple-social-icons-2 ul li a:focus { outline: 1px dotted #f5f5f5 !important; }</style><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Linux Foundation deal --><script type="text/javascript" src="https://a.optmnstr.com/app/js/api.min.js" data-campaign="mn0yal7qv5vzro6npevg" data-user="447" data-env="production"></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Linux Handbook FullPage --><script type="text/javascript" src="https://a.optmnstr.com/app/js/api.min.js" data-campaign="ju5dav87ido2kitcjom0" data-user="447" data-env="production"></script><!-- / OptinMonster -->		<script type="text/javascript">var mn0yal7qv5vzro6npevg_shortcode = true;var ju5dav87ido2kitcjom0_shortcode = true;</script>
		<script id="llms-inline-footerscripts" type="text/javascript">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</script><!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://c0.wp.com/p/jetpack/6.8/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var wp_ajax_data = {"nonce":"c6b68c6466"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms//assets/js/llms.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201849'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/tooltip.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/mouse.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/slider.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/vendor/webui-popover/jquery.webui-popover.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/js/llms-ajax.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/lifterlms/assets/js/llms-form-checkout.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/wp-udemy-pro/public/js/scripts.min.js?ver=1.0.7'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/hoverIntent.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.5'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=2.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"combine":[".nav-primary"],"others":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis-sample/js/responsive-menus.min.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/themes/genesis-sample/js/genesis-sample.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_dash_front = {"ajaxurl":"https:\/\/linuxhandbook.com\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/thrive-comments/thrive-dashboard/js/dist/frontend.min.js?ver=2.0.75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":20,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["ezw_tco-2"]}];
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.4'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/backbone.min.js'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/thrive-comments/assets/js/frontend.min.js?ver=1.1.13'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/linuxhandbook.com\/wp-admin\/admin-ajax.php","nonce":"d53931ac58","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/linuxhandbook.com\/wp-login.php?redirect_to=https%3A%2F%2Flinuxhandbook.com%2Fscp-command%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.8/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=1.5.5'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/vendor/waypoints/jquery.waypoints.min.js?ver=1.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"30","affixSelector":"sidebar"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=1.7'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201849.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8',blog:'144306046',post:'948',tz:'0',srv:'linuxhandbook.com'} ]);
	_stq.push([ 'clickTrackerInit', '144306046', '948' ]);
</script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://linuxhandbook.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '7c56778fed', slugs: {"mn0yal7qv5vzro6npevg":{"slug":"mn0yal7qv5vzro6npevg","mailpoet":false},"ju5dav87ido2kitcjom0":{"slug":"ju5dav87ido2kitcjom0","mailpoet":false}} };</script>
		</body></html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1543929676 -->