<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head >
<meta charset="UTF-8" /><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>How to Check Debian Version in Linux Terminal [Easily]</title>

<!-- Powered by Social Snap v1.1.5.4 - https://socialsnap.com/ -->
<meta property="og:type" content="article">
<meta property="og:title" content="How to Check Which Debian Version are you Running">
<meta property="og:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal.">
<meta property="og:url" content="https://linuxhandbook.com/check-debian-version/">
<meta property="og:site_name" content="Linux Handbook">
<meta property="og:updated_time" content="2019-08-18T12:17:53+00:00">
<meta property="og:image" content="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&#038;ssl=1">
<meta property="og:image:width" content="800">
<meta property="og:image:height" content="450">
<meta property="article:published_time" content="2019-08-16T09:24:06+00:00">
<meta property="article:modified_time" content="2019-08-18T12:17:53+00:00">
<meta property="fb:app_id" content="1923155921341058">
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="How to Check Which Debian Version are you Running">
<meta name="twitter:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal.">
<meta name="twitter:image:src" content="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&ssl=1">
<!-- Powered by Social Snap v1.1.5.4 - https://socialsnap.com/ -->


<meta property="og:type" content="article">
<meta property="og:title" content="How to Check Which Debian Version are you Running">
<meta property="og:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal.">
<meta property="og:url" content="https://linuxhandbook.com/check-debian-version/">
<meta property="og:site_name" content="Linux Handbook">
<meta property="og:updated_time" content="2019-08-18T12:17:53+00:00">
<meta property="og:image" content="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&#038;ssl=1">
<meta property="og:image:width" content="800">
<meta property="og:image:height" content="450">
<meta property="article:published_time" content="2019-08-16T09:24:06+00:00">
<meta property="article:modified_time" content="2019-08-18T12:17:53+00:00">
<meta property="fb:app_id" content="1923155921341058">
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="How to Check Which Debian Version are you Running">
<meta name="twitter:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal.">
<meta name="twitter:image:src" content="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&ssl=1"><!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="rMSRiwTYGujwxoSuof32l6eh2Lugx8LGxfMvwX5q5VE" />
<meta name="dc.title" content="How to Check Debian Version in Linux Terminal [Easily]" />
<meta name="dc.description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal." />
<meta name="dc.relation" content="https://linuxhandbook.com/check-debian-version/" />
<meta name="dc.source" content="https://linuxhandbook.com/" />
<meta name="dc.language" content="en_US" />
<meta name="description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal." />
<link rel="canonical" href="https://linuxhandbook.com/check-debian-version/" />
<meta property="og:url" content="https://linuxhandbook.com/check-debian-version/" />
<meta property="og:site_name" content="Linux Handbook" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Check Debian Version in Linux Terminal [Easily]" />
<meta property="og:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal." />
<meta property="og:image" content="https://linuxhandbook.com/wp-content/uploads/check-debian-version.png" />
<meta property="og:image:secure_url" content="https://linuxhandbook.com/wp-content/uploads/check-debian-version.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta property="og:image:alt" content="Check Debian Version" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="How to Check Debian Version in Linux Terminal [Easily]" />
<meta name="twitter:description" content="Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal." />
<meta name="twitter:image:src" content="https://linuxhandbook.com/wp-content/uploads/check-debian-version.png" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//a.opmnstr.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; Feed" href="https://linuxhandbook.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; Comments Feed" href="https://linuxhandbook.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Handbook &raquo; How to Check Which Debian Version are you Running Comments Feed" href="https://linuxhandbook.com/check-debian-version/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='atomic-blocks-fontawesome-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/assets/fontawesome/css/all.min-1563945902.css' type='text/css' media='all' />
<link rel='stylesheet' id='authority-pro-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/authority-pro/style-1.2.0.css' type='text/css' media='all' />
<style id='authority-pro-inline-css' type='text/css'>

		.single .content .entry-content > p:first-of-type {
			color: #111111;
			font-size: 20px;
			font-style: italic;
			line-height: 1.7;
			margin: 0 0 35px;
		}
		
		a,
		h4,
		h5,
		button,
		input[type="button"],
		input[type="reset"],
		input[type="submit"],		
		.authority-subtitle,
		.button,
		.genesis-nav-menu .highlight a,
		.more-link,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.genesis-responsive-menu .genesis-nav-menu a:focus,
		.genesis-responsive-menu .genesis-nav-menu a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"],
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"],
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #6737d9;
		}

		button,
		input[type="button"],
		input[type="reset"],
		input[type="submit"],
		.button,
		.genesis-nav-menu .highlight a,
		.more-link,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"],
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"] {
			border-color: #6737d9;
		}

		.enews-widget::after,
		.sidebar .enews-widget:nth-child(2n+1)::after {
			background: #6737d9;
		}

		button.primary,
		input[type="button"].primary,
		input[type="reset"].primary,
		input[type="submit"].primary,
		.authority-top-banner,
		.button.primary,
		.more-link,
		.sidebar .enews-widget input[type="submit"],
		.enews-widget input[type="submit"] {
			background-color: #6737d9;
			color: #ffffff;
		}

		.authority-top-banner a,
		.authority-top-banner a:focus,
		.authority-top-banner a:hover,
		#authority-top-banner-close,
		#authority-top-banner-close:focus,
		#authority-top-banner-close:hover {
			color: #ffffff;
		}

		.archive-pagination .pagination-next > a,
		.archive-pagination .pagination-previous > a,
		.menu-toggle,
		.sub-menu-toggle {
			border-color: #6737d9;
			color: #6737d9;
		}

		a.button:focus,
		a.button:hover,
		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.archive-pagination li a:focus,
		.archive-pagination li a:hover,
		.archive-pagination .active a,
		.archive-pagination .pagination-next > a:focus,
		.archive-pagination .pagination-next > a:hover,
		.archive-pagination .pagination-previous > a:focus,
		.archive-pagination .pagination-previous > a:hover,
		.button:focus,
		.button:hover,
		.enews-widget input[type="submit"]:focus,
		.enews-widget input[type="submit"]:hover,
		.genesis-nav-menu .highlight a:focus,
		.genesis-nav-menu .highlight a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.more-link:focus,
		.more-link:hover,
		.sidebar .enews-widget input[type="submit"]:focus,
		.sidebar .enews-widget input[type="submit"]:hover,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:focus,
		.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:hover,
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:focus,
		.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			background-color: #7b4bed;
			border-color: #7b4bed;
			color: #ffffff;
		}
		
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='atomic-blocks-style-css-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/blocks.style.build-1563945902.css' type='text/css' media='all' />
<link rel='stylesheet' id='socialsnap-styles-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/socialsnap-pro/assets/css/socialsnap-1.1.5.4.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-coupons-styles-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/wp-coupons/css/style-1.6.1.css' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min-1.7.css' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/easy-table-of-contents/assets/css/screen.min-1.7.css' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='ufwp_styles-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy/public/css/styles.min-1.1.3.css' type='text/css' media='all' />
<link rel='stylesheet' id='ufwp_pro_styles-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy-pro/public/css/styles.min-1.0.8.css' type='text/css' media='all' />
<link rel='stylesheet' id='authority-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A600%2C700%2C900%7CLibre+Baskerville%3A400%2C400italic%2C700&#038;ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='authority-pro-gutenberg-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/authority-pro/lib/gutenberg/front-end-1.2.0.css' type='text/css' media='all' />
<style id='authority-pro-gutenberg-inline-css' type='text/css'>
.ab-block-post-grid a.ab-block-post-grid-more-link,
.ab-block-post-grid .ab-post-grid-items .ab-block-post-grid-title a:focus,
.ab-block-post-grid .ab-post-grid-items .ab-block-post-grid-title a:hover,
.wp-block-image.vertical-caption figcaption a:focus,
.wp-block-image.vertical-caption figcaption a:hover {
	color: #6737d9;
}

.site-container .ab-button,
.site-container .ab-newsletter-submit,
.site-container .ab-newsletter-submit:hover,
.site-container .wp-block-button .wp-block-button__link,
.wp-block-media-text .wp-block-media-text__media::after,
.wp-block-image.stylized-background::after {
	background-color: #6737d9;
}

.site-container .ab-button,
.wp-block-button .wp-block-button__link:not(.has-background),
.wp-block-button .wp-block-button__link:not(.has-background):focus,
.wp-block-button .wp-block-button__link:not(.has-background):hover {
	color: #ffffff;
}

.site-container .wp-block-button.is-style-outline .wp-block-button__link {
	color: #6737d9;
}

.site-container .wp-block-button.is-style-outline .wp-block-button__link:focus,
.site-container .wp-block-button.is-style-outline .wp-block-button__link:hover {
	color: #8a5afc;
}		.site-container .has-small-font-size {
			font-size: 12px;
		}		.site-container .has-normal-font-size {
			font-size: 16px;
		}		.site-container .has-large-font-size {
			font-size: 20px;
		}		.site-container .has-larger-font-size {
			font-size: 24px;
		}		.site-container .has-theme-primary-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-primary-color,
		.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-primary-color {
			color: #6737d9;
		}

		.site-container .has-theme-primary-background-color,
		.site-container .wp-block-button .wp-block-button__link.has-theme-primary-background-color,
		.site-container .wp-block-pullquote.is-style-solid-color.has-theme-primary-background-color {
			background-color: #6737d9;
		}
</style>
<link rel='stylesheet' id='tcm-front-styles-css-css'  href='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/css/styles-1.2.4.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-auth-check-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/wp-auth-check.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.6/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/js/libs-frontend.min-1.2.4.js'></script>
<link rel='https://api.w.org/' href='https://linuxhandbook.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxhandbook.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxhandbook.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='How to Know if a User has Sudo Rights' href='https://linuxhandbook.com/check-if-user-has-sudo-rights/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://wp.me/p9LuAS-2WG' />
<link rel="alternate" type="application/json+oembed" href="https://linuxhandbook.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxhandbook.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style><style type="text/css">#ss-share-hub > a::after{background-color:#4f89e1} #ss-share-hub > a{color:#fff}</style><style>

	/* for unique landing page accent color values,  put any new css added here inside tcb-bridge/js/editor */

	/* accent color */
	#thrive-comments .tcm-color-ac,
	#thrive-comments .tcm-color-ac span {
		color: #6737d9;
	}

	/* accent color background */
	#thrive-comments .tcm-background-color-ac,
	#thrive-comments .tcm-background-color-ac-h:hover span,
	#thrive-comments .tcm-background-color-ac-active:active {
		background-color: #6737d9	}

	/* accent color border */
	#thrive-comments .tcm-border-color-ac {
		border-color: #6737d9;
		outline: none;
	}

	#thrive-comments .tcm-border-color-ac-h:hover {
		border-color: #6737d9;
	}

	#thrive-comments .tcm-border-bottom-color-ac {
		border-bottom-color: #6737d9;
	}

	/* accent color fill*/
	#thrive-comments .tcm-svg-fill-ac {
		fill: #6737d9;
	}

	/* accent color for general elements */

	/* inputs */
	#thrive-comments textarea:focus,
	#thrive-comments input:focus {
		border-color: #6737d9;
		box-shadow: inset 0 0 3px #6737d9;
	}

	/* links */
	#thrive-comments a {
		color: #6737d9;
	}

	/*
	* buttons and login links
	* using id to override the default css border-bottom
	*/
	#thrive-comments button,
	#thrive-comments #tcm-login-up,
	#thrive-comments #tcm-login-down {
		color: #6737d9;
		border-color: #6737d9;
	}

	/* general buttons hover and active functionality */
	#thrive-comments button:hover,
	#thrive-comments button:active {
		background-color: #6737d9	}

</style>

<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-24863836-8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-24863836-8');
</script>

<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/cropped-linux-handbook-logo-600x600.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/cropped-linux-handbook-logo-600x600.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/cropped-linux-handbook-logo-600x600.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/cropped-linux-handbook-logo-600x600.png?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				.entry-content code {
 color: #e9e5dd;
 background: #2d3561;
 padding: 0 .3em 0.3em;
}
.entry-content pre {
 color: #e9e5dd;
 background: #2d3561;
 padding: .5em 1em;
 border-radius: 0px;	
 overflow: auto;
}			</style>
		</head>
<body class="post-template-default single single-post postid-11326 single-format-standard wp-embed-responsive header-full-width content-sidebar" itemscope itemtype="https://schema.org/WebPage"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-container"><h2 id="additional-menu-label" class="screen-reader-text">Additional menu</h2><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://linuxhandbook.com/">Linux Handbook</a></p><p class="site-description" itemprop="description">Linux Command Line, Server, DevOps and Cloud</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-top" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-1699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1699"><a href="https://linuxhandbook.com/about/" itemprop="url"><span itemprop="name">About</span></a>
<ul class="sub-menu">
	<li id="menu-item-9856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9856"><a href="https://linuxhandbook.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
</ul>
</li>
<li id="menu-item-11071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11071"><a href="https://linuxhandbook.com/category/linux-commands/" itemprop="url"><span itemprop="name">Linux Commands</span></a></li>
<li id="menu-item-11072" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11072"><a href="https://linuxhandbook.com/category/tips/" itemprop="url"><span itemprop="name">Tips</span></a></li>
<li id="menu-item-11073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11073"><a href="https://linuxhandbook.com/category/tutorial/" itemprop="url"><span itemprop="name">Tutorial</span></a></li>
<li id="menu-item-10665" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10665"><a href="https://linuxhandbook.com/deals/" itemprop="url"><span itemprop="name">Linux Deals</span></a></li>
</ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://linuxhandbook.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://linuxhandbook.com/category/tips/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Tips</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> How to Check Which Debian Version are you Running</div><article class="post-11326 post type-post status-publish format-standard has-post-thumbnail category-tips tag-debian entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to Check Which Debian Version are you Running</h1>
<p class="entry-meta">Last Updated on <time class="entry-modified-time" itemprop="dateModified" datetime="2019-08-18T12:17:53+00:00">August 18, 2019</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://linuxhandbook.com/author/abhishek/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Abhishek</span></a></span> <span class="entry-comments-link"><a href="https://linuxhandbook.com/check-debian-version/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text">
<p><strong><em>Brief: Wondering which Debian version are you running? This tutorial teaches you several ways to check Debian version in the terminal.</em></strong></p>



<p>Which Debian version am I running? You need the answer in situations such as when you are looking for a software that is available for certain Debian version only.</p>



<p>Knowing Debian version is helpful in a lot of situation. Here&#8217;s how to do it.</p>



<h2>How to check Debian version?</h2>



<p>The simplest way you can check Debian version is using the lsb_release command:</p>



<pre class="wp-block-code"><code>lsb_release -a</code></pre>



<p>Here&#8217;s the output:</p>



<pre class="wp-block-code"><code>pi@raspberrypi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID:	Raspbian
Description:	Raspbian GNU/Linux 10 (buster)
Release:	10
Codename:	buster</code></pre>



<p>I am running Raspbian OS which is Debian customized for <a href="https://www.raspberrypi.org/" target="_blank" rel="noreferrer noopener" aria-label="Raspberry Pi (opens in a new tab)">Raspberry Pi</a>. As you can see, I am running <a rel="noreferrer noopener" aria-label="Debian 10 Buster (opens in a new tab)" href="https://wiki.debian.org/DebianBuster" target="_blank">Debian 10 Buster</a> here.</p>



<p>The lsb_release is my favorite command as it can be used to check the version of most Linux distribution (if not all). For example, you can use it to <a href="https://linuxhandbook.com/check-centos-version/" target="_blank" rel="noreferrer noopener" aria-label="check CentOS version (opens in a new tab)">check CentOS version</a> as well.</p>



<p>But that&#8217;s not the only way. There are other commands to find Debian version in Linux terminal.</p>



<h2>Other methods to show Debian version</h2>



<figure class="wp-block-image"><img data-attachment-id="11388" data-permalink="https://linuxhandbook.com/check-debian-version/check-debian-version-2/" data-orig-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Check Debian Version" data-image-description data-medium-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?ssl=1" alt="Check Debian Version" class="wp-image-11388 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?w=800&amp;ssl=1 800w, https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?resize=768%2C432&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="11388" data-permalink="https://linuxhandbook.com/check-debian-version/check-debian-version-2/" data-orig-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Check Debian Version" data-image-description="" data-medium-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?ssl=1" alt="Check Debian Version" class="wp-image-11388" srcset="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?w=800&amp;ssl=1 800w, https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript></figure>



<p>Do you recall the <a rel="noreferrer noopener" aria-label="Linux directory structure (opens in a new tab)" href="https://linuxhandbook.com/linux-directory-structure/" target="_blank">Linux directory structure</a>? The /etc directory has the core configuration files and you can use them to find a lot of useful information about your system including the distribution version number.</p>



<p>Here are two ways to do that:</p>



<pre class="wp-block-code"><code>pi@raspberrypi:~ $ cat /etc/issue
Raspbian GNU/Linux 10 \n \l</code></pre>



<p>The above command output shows that I am running Raspbian GNU Linux 10. If you don&#8217;t like the way this output is presented, you can use this method to get just the version number of Debian.</p>



<pre class="wp-block-code"><code>pi@raspberrypi:~ $ cat /etc/debian_version 
10.0</code></pre>



<p>But this one misses other crucial information. This is why recommend reading the dedicated file for this purpose:</p>



<pre class="wp-block-code"><code>cat /etc/os-release</code></pre>



<p>Its output will show you a number of information like version umber, the code name and the project related URLs.</p>



<pre class="wp-block-code"><code>pi@raspberrypi:~ $ cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"</code></pre>



<p>Another evergreen way is to use systemd command hostnamectl. It&#8217;s mainly used for managing the hostname but you can also use it to get Debian version along with the kernel version.</p>



<pre class="wp-block-code"><code>hostnamectl</code></pre>



<p>You can see the Debian version under the Operating System line.</p>



<pre class="wp-block-code"><code>pi@raspberrypi:~ $ hostnamectl 
   Static hostname: raspberrypi
         Icon name: computer
        Machine ID: 0035faf761f945b8923fc7d54632a941
           Boot ID: 6de8d489b3a24b6996bd08c9992a6de3
  Operating System: Raspbian GNU/Linux 10 (buster)
            Kernel: Linux 4.19.29-v7l+
      Architecture: arm</code></pre>



<p>So, you just saw five ways to check Debian version. Which command did you like the most? Let me know in the comments. </p>
<span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><img src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" class="ss-hidden-pin-image jetpack-lazy-image" data-pin-url="https://linuxhandbook.com/check-debian-version/" data-pin-media="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1" data-pin-description="How to Check Which Debian Version are you Running" data-lazy-src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&ssl=1" class="ss-hidden-pin-image" data-pin-url="https://linuxhandbook.com/check-debian-version/" data-pin-media="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/check-debian-version.png?fit=800%2C450&ssl=1" data-pin-description="How to Check Which Debian Version are you Running"/></noscript>		<div class="ss-inline-share-wrapper ss-hover-animation-fade ss-with-counter-border ss-inline-total-counter-left ss-left-inline-content ss-small-icons ss-with-spacing ss-rounded-icons ss-both-labels">

							<p class="ss-social-share-label">
					<span>Liked the article? Please share it and help us grow :)</span>
				</p>
						
			<div class="ss-inline-share-content">
				
				
			<!-- Total share counter -->
			<div class="ss-inline-counter">

			
		
		<span class="ss-total-counter ss-total-shares ss-share-inline_content-total-shares" data-ss-ss-post-id="11326">
			<span>3</span>
			<span>Shares</span>
		</span>

					</div>
						
		<ul class="ss-social-icons-container">

							<li class="">

					
						
						<a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=How%20to%20Check%20Which%20Debian%20Version%20are%20you%20Running&#038;u=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F" class="ss-facebook-color" rel="nofollow"  data-ss-ss-network-id="facebook" data-ss-ss-post-id="11326" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://linuxhandbook.com/check-debian-version/" data-ss-ss-type="share" data-has-api="true">
					
						<span class="ss-share-network-content">
							<i class="ss ss-facebook"></i>

																<span class="ss-network-label">Facebook</span>
																<span class="ss-network-count">
									0		
								</span>
							
						</span>

											</a>
					
									</li>
							<li class="">

					
						
						<a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=How+to+Check+Which+Debian+Version+are+you+Running&#038;url=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F&#038;via=linuxhandbook" class="ss-twitter-color" rel="nofollow"  data-ss-ss-network-id="twitter" data-ss-ss-post-id="11326" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://linuxhandbook.com/check-debian-version/" data-ss-ss-type="share">
					
						<span class="ss-share-network-content">
							<i class="ss ss-twitter"></i>

																<span class="ss-network-label">Twitter</span>
																<span class="ss-network-count">
									0		
								</span>
							
						</span>

											</a>
					
									</li>
							<li class="">

					
						
						<a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=How%20to%20Check%20Which%20Debian%20Version%20are%20you%20Running&#038;url=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F&#038;mini=true" class="ss-linkedin-color" rel="nofollow"  data-ss-ss-network-id="linkedin" data-ss-ss-post-id="11326" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://linuxhandbook.com/check-debian-version/" data-ss-ss-type="share">
					
						<span class="ss-share-network-content">
							<i class="ss ss-linkedin"></i>

																<span class="ss-network-label">LinkedIn</span>
																<span class="ss-network-count">
									0		
								</span>
							
						</span>

											</a>
					
									</li>
							<li class="">

					
						
						<a href="#" data-ss-ss-link="https://www.reddit.com/submit?title=How%20to%20Check%20Which%20Debian%20Version%20are%20you%20Running&#038;url=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F" class="ss-reddit-color" rel="nofollow"  data-ss-ss-network-id="reddit" data-ss-ss-post-id="11326" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://linuxhandbook.com/check-debian-version/" data-ss-ss-type="share" data-has-api="true">
					
						<span class="ss-share-network-content">
							<i class="ss ss-reddit"></i>

																<span class="ss-network-label">Reddit</span>
																<span class="ss-network-count">
									0		
								</span>
							
						</span>

											</a>
					
									</li>
			
					</ul>
					
			</div><!-- END .ss-inline-share-content -->
		</div><!-- END .ss-inline-share-wrapper -->
		<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://linuxhandbook.com/get-shell-script-execution-time/" target="_blank" class="u9ed154683aa8fce9bed9e469b82133f2"><!-- INLINE RELATED POSTS 1/3 //--><style> .u9ed154683aa8fce9bed9e469b82133f2 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#eaeaea; border:0!important; border-left:4px solid #34495E!important; text-decoration:none; } .u9ed154683aa8fce9bed9e469b82133f2:active, .u9ed154683aa8fce9bed9e469b82133f2:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u9ed154683aa8fce9bed9e469b82133f2 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u9ed154683aa8fce9bed9e469b82133f2 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u9ed154683aa8fce9bed9e469b82133f2 .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u9ed154683aa8fce9bed9e469b82133f2:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ</span>&nbsp; <span class="postTitle">Print Execution Time of Shell Script in Linux</span></div></a></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://linuxhandbook.com/category/tips/" rel="category tag">Tips</a></span> <span class="entry-tags">Tagged With: <a href="https://linuxhandbook.com/tag/debian/" rel="tag">debian</a></span></p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt src="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=124&#038;d=mm&#038;r=g" class="avatar avatar-124 photo jetpack-lazy-image" height="124" width="124" data-lazy-srcset="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=248&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=124&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=124&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=248&#038;d=mm&#038;r=g 2x' class='avatar avatar-124 photo' height='124' width='124' /></noscript><h4 class="author-box-title">About <span itemprop="name">Abhishek</span></h4><div class="author-box-content" itemprop="description"><p>Software Professional, Linux Geek, Open Source Enthusiasts and Classic Detective Mystery Lover. Helping people with Linux is my ultimate goal.</p>
</div></section><div id="comments" class="comments-compat-authority-pro">
	<div id="thrive-comments" class="clearfix">
		<div class="tcm-dot-loader">
			<span class="inner1"></span>
			<span class="inner2"></span>
			<span class="inner3"></span>
		</div>
		<div class="thrive-comments-content">
			<div class="tcm-comments-filter"></div>
			<div class="tcm-comments-create"></div>
			<div class="tcm-comments-list">
							</div>
			<div class="tcm-lazy-comments"></div>
		</div>
	</div>
</div>
</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-2" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://linuxhandbook.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://linuxhandbook.com/?s={s}"></form></div></section>
<section id="socialsnap-social-followers-widget-2" class="widget socialsnap-social-followers-widget"><div class="widget-wrap">
			<h4 class="ss-follow-total-counter">
				<strong>43K</strong> Followers			</h4>
		
		<div class="ss-follow-wrapper ss-clearfix ss-regular-buttons ss-columns-1 ss-network-style">

			
				<div class="ss-follow-column" data-ss-sf-network-id="facebook">
					<a href="https://facebook.com/linuxhandbook/" class="ss-follow-network ss-facebook-color" rel="nofollow" target="_blank">
						<i class="ss ss-facebook"></i>

													<span class="ss-follow-network-label">Follow us on Facebook</span>
						
						
							<span class="ss-follow-network-count">
								<span class="ss-follow-network-count-number">43K</span>
								<span class="ss-follow-network-count-label">Followers</span>
							</span>

											</a>
				</div><!-- END .ss-follow-column -->

			
				<div class="ss-follow-column" data-ss-sf-network-id="twitter">
					<a href="https://twitter.com/LinuxHandbook/" class="ss-follow-network ss-twitter-color" rel="nofollow" target="_blank">
						<i class="ss ss-twitter"></i>

													<span class="ss-follow-network-label">Follow us on Twitter</span>
						
						
							<span class="ss-follow-network-count">
								<span class="ss-follow-network-count-number">0</span>
								<span class="ss-follow-network-count-label">Followers</span>
							</span>

											</a>
				</div><!-- END .ss-follow-column -->

			
				<div class="ss-follow-column" data-ss-sf-network-id="youtube">
					<a href="https://www.youtube.com/channel/UCYA-a-_cqXk72eTh3VoCKDQ" class="ss-follow-network ss-youtube-color" rel="nofollow" target="_blank">
						<i class="ss ss-youtube"></i>

													<span class="ss-follow-network-label">Follow us on YouTube</span>
						
						
							<span class="ss-follow-network-count">
								<span class="ss-follow-network-count-number">0</span>
								<span class="ss-follow-network-count-label">Followers</span>
							</span>

											</a>
				</div><!-- END .ss-follow-column -->

					</div>

		</div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><a href="https://brave.com/lin560" target="_blank" rel="noopener noreferrer"><img class="aligncenter wp-image-11086 size-full jetpack-lazy-image" src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/brave-standard-300x100.png?resize=300%2C100&#038;ssl=1" alt="Brave Standard" width="300" height="100" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/brave-standard-300x100.png?resize=300%2C100&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="aligncenter wp-image-11086 size-full" src="https://i0.wp.com/linuxhandbook.com/wp-content/uploads/brave-standard-300x100.png?resize=300%2C100&#038;ssl=1" alt="Brave Standard" width="300" height="100" data-recalc-dims="1" /></noscript></a></p>
</div>
		</div></section>
<section id="text-6" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div id="codefund"><!-- fallback content --></div>
<p><script src="https://codefund.io/properties/343/funder.js" async="async"></script></p>
</div>
		</div></section>
<section id="wp_coupons_widget-2" class="widget widget_wp_coupons_widget"><div class="widget-wrap"><style>
			/*Archive Template Only*/
			#wp-coupons-outer-wrapper {
				padding-left: 20px;
				padding-right: 20px;
			}
			#wp-coupons-wrapper {
				max-width: 1200px;
			}
			/*Navigation*/
			body .wp-coupons-nav a, body .wp-coupons-nav a:visited {
				font-size: 24px;
				color: #237dac;
			}
			body .wp-coupons-nav a:hover, body .wp-coupons-nav a.wp-coupons-nav-selected {
				color: #0872aa;
			}
			body .wp-coupons-subnav a, body .wp-coupons-subnav a:visited {
				font-size: 18px;
				color: #237dac;
				border-color: #237dac;
			}
			body .wp-coupons-subnav a.active, body .wp-coupons-subnav a:hover {
				color: #0872aa;
				border-color: #0872aa;
			}
			/*Coupon Panel*/
			.wp-coupons-coupon-panel {
				background: #e6e9ee;
			}
			.wp-coupons-coupon-panel .wp-coupons-discount-percent {
				background: #6737d9;
				color: #ffffff;
				font-size: 16px;
			}
			.wp-coupons-coupon-panel .wp-coupons-expiration {
				color: #999999;
				font-size: 14px;
			}
			 .wp-coupons-coupon-panel .wp-coupons-discount-code {
				background: #237dac;
				color: #ffffff;
				font-size: 16px;
			}
			.wp-coupons-coupon-panel .wp-coupons-discount-code span {
				color: #ffffff;
				border-color: #ffffff;
			}
			.wp-coupons-coupon-panel .wp-coupons-ctr:before {
				border-color: #1f6e96 transparent;
			}
			.wp-coupons-coupon-panel .wp-coupons-ctr:after {
				border-color: #237dac;
			}
			.wp-coupons-coupon-panel .coupon-separator {
				border-color: #d0d2d7;
			}
			.wp-coupons-coupon-panel .coupon-title {
				font-size: 20px;
			}
			.wp-coupons-coupon-panel .coupon-title, .wp-coupons-coupon-panel .coupon-title:visited, .wp-coupons-coupon-panel .coupon-link, .wp-coupons-coupon-panel .coupon-link:visited, .wp-coupons-banner .coupon-title {
				color: #237dac;
			}
			.wp-coupons-coupon-panel .coupon-title:hover, .wp-coupons-coupon-panel .coupon-link:hover {
				color: #0872aa;
			}
			.wp-coupons-coupon-panel .coupon-description {
				font-size: 18px;
				line-height: 28px;
				min-height: 90px;
				max-height: 90px;
			}
			.wp-coupons-coupon-panel .coupon-type, .wp-coupons-coupon-panel .coupon-type:hover, .wp-coupons-coupon-panel .coupon-type:visited {
				color: #2c3644;
				font-size: 16px;
			}
			.wp-coupons-coupon-panel a.coupon-link {
				font-size: 16px;
			}
			/*Pagination*/
			body .wp-coupons-navigation .page-numbers, body .wp-coupons-navigation .page-numbers:visited {
				background-color: #237dac;
			}
			body .wp-coupons-navigation .page-numbers.current, body .wp-coupons-navigation .page-numbers:hover {
				background-color: #0872aa;
			}
			/*Click to Reveal Popup*/
			#wp-coupons-ctr-popup #wp-coupons-ctr-discount-code span {
				background: #237dac;
				color: #ffffff;
			}
			#wp-coupons-ctr-popup #wp-coupons-ctr-discount-url a {
				color: #237dac;
			}
			#wp-coupons-ctr-popup #wp-coupons-ctr-discount-url a:hover {
				color: #0872aa;
			}
			/*Buttons*/
			body a.wp-coupons-button {
				background: #237dac;
				border-color: #237dac;
				font-size: 16px;
			}
			body a.wp-coupons-button:hover {
				color: #0872aa;
				border-color: #0872aa;
			}
			@media(min-width: 794px) {
				.wp-coupons-coupon.list.compact .wp-coupons-coupon-panel .coupon-link, .wp-coupons-coupon.list.minimal .wp-coupons-coupon-panel .coupon-link {
					font-size: 18px;
					line-height: 28px;
				}
			}
		</style><div class='wp-coupons-widget'><div class='wp-coupons-coupon-panel'><div class='coupon-panel-image-wrapper' style='position: relative; overflow: hidden;'><div class='wp-coupons-discount-percent'>Get $50 Free Credits</div><a href='https://m.do.co/c/d58840562553' class='' target='_blank' title='DigitalOcean Cloud Server' rel='nofollow'><img width="800" height="400" src="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?fit=800%2C400&amp;ssl=1" class="attachment-full size-full wp-post-image jetpack-lazy-image" alt="Digital Ocean Cloud Server Deal" data-attachment-id="10657" data-permalink="https://linuxhandbook.com/deals/digitalocean/digital-ocean-cloud-server-deal/" data-orig-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?fit=800%2C400&amp;ssl=1" data-orig-size="800,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Digital Ocean Cloud Server Deal" data-image-description="" data-medium-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?fit=300%2C150&amp;ssl=1" data-large-file="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?fit=800%2C400&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?w=800&amp;ssl=1 800w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?resize=300%2C150&amp;ssl=1 300w, https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?resize=768%2C384&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i1.wp.com/linuxhandbook.com/wp-content/uploads/digital-ocean-cloud-server-deal.jpeg?fit=800%2C400&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div><div class='wp-coupons-coupon-content' style='padding: 0px 25px 10px 25px; overflow: hidden;'><a href='https://m.do.co/c/d58840562553' class='' target='_blank' title='DigitalOcean Cloud Server' rel='nofollow'><h2 class='coupon-title'>DigitalOcean Cloud Server</h2></a><div class='coupon-description'>Deploy your apps in cloud in one click with hassle-free pre-configured Linux servers.</div><a href='https://m.do.co/c/d58840562553' title='' class='wp-coupons-button ' target='_blank' rel='nofollow'>Get This Deal</a></div></div></div></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-11077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11077"><a href="https://linuxhandbook.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-9528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9528"><a href="https://linuxhandbook.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-11076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11076"><a href="https://linuxhandbook.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-11078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11078"><a href="https://linuxhandbook.com/feed/" itemprop="url"><span itemprop="name">Feed</span></a></li>
</ul></div></nav><p>Copyright &#x000A9;&nbsp;2019 chmod777 · Built On <a href="https://shareasale.com/r.cfm?b=242694&#038;u=747593&#038;m=28169&#038;urllink=&#038;afftrack=">Genesis Framework</a> · <a href="https://wordpress.org/">WordPress</a> · <a href="https://linuxhandbook.com/wp-login.php">Log in</a></p></div></footer></div><script type="text/template" id="comments-conversion"><# if ( html_switch === 'tcm_live_update' ) { #>
	<div class="tcm-thank-you-submited tcm-border-color-ac">
		<#= custom_message #>
	</div>
<# } #>
<# if ( html_switch === 'tcm_related_posts' ) { #>
	<div class="tcm-posts tcm-border-color-ac">
	        <#= custom_message #>
	        <div class="tcm-posts-list <# if ( ! show_featured_image ) { #> no-featured-image <# } #> clear-this posts-length-<#= ThriveComments.related_posts.length #>">
		        <# ThriveComments.related_posts.forEach( function ( value ) { #>
			        <div class="tcm-post tcm-color-ac <# if ( ! show_featured_image ) { #> tcm-border-bottom-color-ac <# } #>">
				        <# if ( show_featured_image ) { #>
				            <div>
		                         <a href="<#= value.guid #>" style="background-image: url(<#= value.featured_image #>)" class="tcm-related-thumbnail <# if ( ! value.featured_image ) { #>tcm-no-featured-image<# } #>">
	                            </a>
				            </div>
					    <# } #>
				        <h3><a href="<#= value.guid #>">

								<span>
									<svg class="related-posts-arrow tcm-svg-fill-ac"><use xlink:href="#tcm-related-posts-arrow"></use></svg>								</span>


								<#= value.post_title #>

								</#></a></h3>
			        </div>
		        <# } ) #>
	        </div>
	</div>
<# } #>
<# if ( html_switch === 'tcm_social_share' ) { #>
	<div class="tcm-share-post tcm-border-color-ac">
		<#= custom_message #>
		<div class="share-buttons">
			<# if ( share_btns.fb_share ) { #><div class="fb-button" data-href="http://www.facebook.com/share.php"></div><# } #>
			<# if ( share_btns.tw_share ) { #><div class="tw-button" data-href="https://twitter.com/intent/tweet"></div><# } #>
			<# if ( share_btns.lk_share ) { #><div class="in-button" data-href="https://www.linkedin.com/cws/share"></div><# } #>
			<# if ( share_btns.pt_share ) { #><div class="pt-button" data-href="http://pinterest.com/pin/create/button"></div><# } #>
			<# if ( share_btns.gg_share ) { #><div class="gm-button" data-href="https://plus.google.com/share"></div><# } #>
			<# if ( share_btns.xi_share ) { #><div class="xi-button" data-href="https://www.xing.com/spi/shares/new"></div><# } #>
		</div>
	</div>
<# } #>
</script><script type="text/template" id="comments-create">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</script><script type="text/template" id="comments-deleted"><div class="tcm-deleted-comment clear-this">
	<div class="deleted-header">
		<div class="moderation-img no-image" data-social-avatar="<#= comment.get('social_avatar') #>" data-email="<#= comment.get('comment_author_email') #>" data-src="<#= comment.get('photo_src') #>" style="background-image: url(<#= comment.get('author_avatar_urls') #>);"></div>
		<div class="deleted-header-text">
			<strong>
				<#= comment.get('author_name') #>
			</strong>
			<span>
				<#= comment.get('formatted_date') #>
			</span>
		</div>
	</div>
	<div class="deleted-text">
		<p class="deleted-info-text tcm-color-ac">
			<# if ( comment.get('status') === 'spam' ) { #>
			<span>This comment was marked as spam</span>
			<# } else { #>
			<span>This comment was marked as trash</span>
			<# } #>
			<a href="#" data-key="z" class="undo-action">Undo</a>
		</p>

		<p>
			<#= comment.get('comment_content') #>
		</p>
	</div>
</div>
</script><script type="text/template" id="comments-item">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</script><script type="text/template" id="comments-lazy-loading"><button class="tcm-loader">
	<div style="display: inline-block" class="tcm-dot-loader done">
		<span class="inner1"></span>
		<span class="inner2"></span>
		<span class="inner3"></span>
	</div>
	<p>
		<#= ThriveComments.util.render_label('load_comments') #>
	</p>
</button>
<# if ( comments_rendered > 2 && ! ThriveComments.close_comments ) { #>
<div class="add-comment tcm-background-color-ac">
	<p>
			<span class="add-comment-icon">
				<svg class="add-comment-svg"><use xlink:href="#tcm-add-comment"></use></svg>			</span>
		<#= ThriveComments.util.render_label('add_comment') #></#></p>
</div>
<# } #>
<# if ( showPoweredBy ) { #>
<div class="tcm-powered-by">
    	<a href="https://thrivethemes.com/comments/" title="Powered by Thrive Comments" target="_blank">
			<span class="tcm-footer-logo">
				<svg class="logo-footer-svg"><use xlink:href="#tcm-logo-footer"></use></svg>			</span>

		<span>
			Powered by 		</span>
		<span>
			Thrive Comments		</span>
	</a>
</div>
<# } #>

<# if ( ! ThriveComments.close_comments && ThriveComments.email_services.length !== 0 ) { #>
	<div class="tcm-align-right">

		<a href="javascript:void(0)" class="tcm-link-unsubscribe" title="<#= ThriveComments.util.render_label('unsubscribe') #>"
		<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) || ( typeof ThriveComments.current_user.ID === 'undefined' ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('unsubscribe') #></a>

		<a href="javascript:void(0)" class="tcm-link-subscribe" title="<#= ThriveComments.util.render_label('subscribe') #>"
		<# if ( - 1 !== ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('subscribe') #></a>

		<div id="tcm-subscribe-form" class="tcm-subscribe-form" hidden>
			<div class="tcm-error-message"></div>
			<input class="form-input tcm-subscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
			<button class="submit-subscribe-post"><#= ThriveComments.util.render_label('subscribe') #></a></button>
		</div>

		<# if ( typeof ThriveComments.current_user.ID === 'undefined' ) { #>
			<div id="tcm-unsubscribe-form" class="tcm-subscribe-form"
			<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID )  ) { #> hidden <# } #> >
				<div class="tcm-error-message"></div>
				<input class="form-input tcm-unsubscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
				<button class="submit-unsubscribe-post"><#= ThriveComments.util.render_label('unsubscribe') #></a></button>
			</div>
		<# } #>
        <p class="tcm-already-subscribed" hidden> Already subscribed! </p>

    </div>
<# } #>
<div class="clear"></div>
</script><script type="text/template" id="comments-list"><div id="tcm-comments-filter" class="tcm-comments-filter">
	<div class="tcm-lazy-loader"></div>
</div></script><script type="text/template" id="comments-moderation"><div class="tcm-moderate-dots tcm-background-color-ac-h">
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
</div>

<div class="tcm-dropdown-moderate">
	<# _.each( actions, function( action, key ){ #>
	<div class="tcm-dropdown-moderate-element" data-fn="<#= action.fn #>" data-value="<#= action.value #>"><#= action.text #></div>
	<# }) #>
</div></script><script type="text/template" id="comments-sort"><div class="tcm-comments-filters">
	<div class="left">
		<div class="tcm-comments-number">
			<#= ThriveComments.util.render_label( 'number_of_comments', 'comment_count' ) #>
		</div>
	</div>
	<div class="right">
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','before') #>
		</label>
		<div name="sort-by" id="tcm-sort-by" class="tcm-dropdown tcm-filter-dropdown tcm-really-random">
            <span class="tcm-toggle-button current-sorting">
                <# if ( ThriveComments.settings.comment_order === 'desc') { #>
					<#= ThriveComments.util.render_label( 'newest') #>
					<# } else if( ThriveComments.settings.comment_order === 'asc') { #>
					<#= ThriveComments.util.render_label( 'oldest') #>
					<# } else {#>
				<# if( ThriveComments.settings.tcm_vote_type != 'no_vote' ) {#>
					<#= ThriveComments.util.render_label( 'top_rated') #>
					<# } #>
				<# } #>
			</span>

			<span class="dropdown-arrow-comments">
						<svg class="sort-by-dropdown-svg"><use xlink:href="#tcm-sort-by-dropdown"></use></svg>			</span>

			<div class="tcm-dropdown-content">

				<div data-value="desc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'newest') #>
				</div>
				<div data-value="asc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'oldest') #>
				</div>
				<# if(ThriveComments.settings.tcm_vote_type != 'no_vote'){#>
				<div data-value="top-rated" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'top_rated') #>
				</div>

				<# } #>

			</div>
		</div>
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','after') #>
		</label>
	</div>
</div>
<div class="clear"></div>
<# if ( ThriveComments.close_comments ) { #>
<div class="tcm-closed-comments" style="text-align: center">
	<p>
		<#= ThriveComments.util.render_label('close_comments') #>
	</p>
</div>
<# } #></script>	<div id="wp-auth-check-wrap" class="hidden">
	<div id="wp-auth-check-bg"></div>
	<div id="wp-auth-check">
	<button type="button" class="wp-auth-check-close button-link"><span class="screen-reader-text">Close dialog</span></button>
			<div id="wp-auth-check-form" class="loading" data-src="https://linuxhandbook.com/wp-login.php?interim-login=1&#038;wp_lang=en_US"></div>
			<div class="wp-auth-fallback">
		<p><b class="wp-auth-fallback-expired" tabindex="0">Session expired</b></p>
		<p><a href="https://linuxhandbook.com/wp-login.php" target="_blank">Please log in again.</a>
		The login page will open in a new tab. After logging in you can close it and return to this page.</p>
	</div>
	</div>
	</div>
	<div style="display: none;">
    <svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"xml:space="preserve">
	<defs>

	<symbol id="tcm-reply" viewBox="0 0 100 100">
			<g>
				<path d="M69.9,38.1L69.9,38.1c-1.5-3.7-4.7-6.4-7.4-9.2c-2.8-2.8-6.3-4.7-9.9-6.3c-3.7-1.6-7.7-2.4-11.7-2.4h-11
					l4.7-4.8c3.4-3.4,3.4-9,0-12.4c-3.4-3.4-8.9-3.4-12.2,0L2.8,22.7c-3.4,3.4-3.4,9,0,12.4l19.4,19.7c1.7,1.7,3.9,2.6,6.1,2.6
					c2.2,0,4.4-0.9,6.1-2.6c3.4-3.4,3.4-9,0-12.4l-4.6-4.6h10.9c3.4,0,6.6,1.4,9.1,3.8l4.8,4.8c1.2,2,3,3.4,5.1,4.1
					c2.1,0.6,4.5,0.4,6.6-0.7C70.5,47.5,72,42.3,69.9,38.1z"/>
				<ellipse cx="81.1" cy="60.8" rx="8.5" ry="8.6"/>
			</g>
	</symbol>

	<symbol id="tcm-icon-thumb_down" viewBox="0 0 24 24">
		<g>
			<path d="M18.984 3h4.031v12h-4.031v-12zM15 3c1.078 0 2.016 0.938 2.016 2.016v9.984c0 0.563-0.234 1.031-0.609
			1.406l-6.563 6.609-1.078-1.078c-0.281-0.281-0.422-0.609-0.422-1.031v-0.328l0.984-4.594h-6.328c-1.078 0-2.016-0.891-2.016-1.969l0.047-0.094h-0.047v-1.922c0-0.281
			0.047-0.516 0.141-0.75l3.047-7.031c0.281-0.703 0.984-1.219 1.828-1.219h9z" />
		</g>
	</symbol>

	<symbol id="tcm-icon-thumb_up" viewBox="0 0 24 24">
		<g>
			<path d="M23.016 9.984l-0.047 0.094h0.047v1.922c0 0.281-0.047 0.516-0.141 0.75l-3.047 7.031c-0.281 0.703-0.984
			1.219-1.828 1.219h-9c-1.078 0-2.016-0.938-2.016-2.016v-9.984c0-0.563 0.234-1.031 0.609-1.406l6.563-6.609 1.078
			1.078c0.281 0.281 0.422 0.609 0.422 1.031v0.328l-0.984 4.594h6.328c1.078 0 2.016 0.891 2.016 1.969zM0.984 21v-12h4.031v12h-4.031z" />
		</g>>

	</symbol>

	<symbol id="tcm-add-comment" viewBox="0 0 267.3 245">
		<path style="fill:#FFFFFF;" class="st0" d="M265.7,61C259.6,27.5,230.3,2,195.1,2H72.5C33,2,0.8,34.2,0.8,73.8v77c0,0.1,0,0.1,0,0.2v81.6
			c0,0-1.8,11.1,9.7,11.1c0,0,4.2,1,13.1-4.6l46.8-43.2h124.6c39.5,0,71.7-32.2,71.7-71.7V83.8L265.7,61z M78.4,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6S93,91.4,93,99.5C93,107.5,86.5,114,78.4,114z M137.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C152.1,107.5,145.5,114,137.5,114z M196.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C211.1,107.5,204.6,114,196.5,114z"/>
	</symbol>

	<symbol id="tcm-logo-footer" viewBox="0 0 130 100">
		<path style="fill:#434343;" class="st0" d="M108.8,26.5C106.7,14.9,96.5,6.1,84.4,6.1H41.9C28.2,6.1,17,17.2,17,30.9v26.7c0,0,0,0,0,0.1v28.2
			c0,0-0.6,3.8,3.4,3.8c0,0,1.5,0.4,4.6-1.6l16.2-14.9h12.1c0.1-0.2,0.3-0.4,0.4-0.6l2.2-3.1c0.4-0.6,1.9-2.3,3.1-3.6H37.6
			c-1.1,0-2.1,0.6-2.8,1.4l0,0L24.1,78.6V58.2c0-0.2,0.1-0.4,0.1-0.6V30.9c0-9.7,7.9-17.6,17.6-17.6h42.5c9.7,0,17.6,7.9,17.6,17.6
			v16.9c2.6-0.4,5.3-0.6,7.2-0.7V34.4L108.8,26.5z"/>
		<path style="fill:#57A245;" class="st1" d="M43.7,39.9c-3.3,0-6-2.7-6-6c0-3.3,2.7-6,6-6h38.9c3.3,0,6,2.7,6,6c0,3.3-2.7,6-6,6H43.7z"/>
		<path style="fill:#434343;" class="st0" d="M43.7,52.2h38.9c2.4,0,4.3-1.9,4.3-4.3s-1.9-4.3-4.3-4.3H43.7c-2.4,0-4.3,1.9-4.3,4.3S41.3,52.2,43.7,52.2"/>
		<path style="fill-rule:evenodd;clip-rule:evenodd;fill:#57A245;" class="st2" d="M118.2,52.4c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4
			c-3.4,4.2-4.1,4.9-6.8,10.2c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5
			c-0.6,0.5-1.3,1-1.9,1.5c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2
			c-0.2,0.1-0.4,0.2-0.5,0.2c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7
			c0.6-1.4,1.3-2.8,2.1-4.1c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6l0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7l4.1-1.9
			c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3
			c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4
			c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6
			c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8
			c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9
			c3.5-0.7,12.3-2.3,16.6-2.3h0.9C114,51.2,117.4,51.2,118.2,52.4z"/>
		<path style="fill:none;" class="st3" d="M99.5,58.5c0.4,0,0.2,0,0.2-0.1C99.4,58.4,99.6,58.4,99.5,58.5z M99.5,58.5c0.1-0.1-0.1-0.1,0.2-0.1
			C99.7,58.5,99.9,58.5,99.5,58.5 M99.9,58.3l-0.1,0.1 M99.5,58.5c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3
			c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3
			c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5
			c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3
			c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8
			c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9c3.5-0.7,12.3-2.3,16.6-2.3h0h0.2h0.6c2.2,0,5.6,0.1,6.4,1.3
			c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4c-3.4,4.2-4.1,4.9-6.8,10.2
			c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5c-0.6,0.5-1.3,1-1.9,1.5
			c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2c-0.2,0.1-0.4,0.2-0.5,0.2
			c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7c0.6-1.4,1.3-2.8,2.1-4.1
			c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6c0.1-0.1,0.2-0.2,0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7L99.5,58.5"/>
	</symbol>

	<symbol id="tcm-related-posts-arrow" viewBox="0 0 16 16">
		<path class="st0" d="M8,15.9c-4.4,0-7.9-3.5-7.9-7.9S3.6,0.1,8,0.1s7.9,3.5,7.9,7.9S12.4,15.9,8,15.9z M8,2.4C4.9,2.4,2.4,4.9,2.4,8
			s2.5,5.6,5.6,5.6s5.6-2.5,5.6-5.6S11.1,2.4,8,2.4z M11.9,8.3l-3.3,3.3c-0.1,0.1-0.2,0.1-0.2,0.1c-0.2,0-0.3-0.2-0.3-0.3v-2H4.4
			C4.2,9.3,4.1,9.2,4.1,9V7c0-0.2,0.2-0.3,0.3-0.3H8v-2c0-0.2,0.1-0.3,0.3-0.3c0.1,0,0.2,0,0.2,0.1l3.3,3.3C11.9,7.9,12,7.9,12,8
			S11.9,8.2,11.9,8.3z"/>
	</symbol>

	<symbol id="tcm-sort-by-dropdown" viewBox="0 0 12 7">
		<path style="fill:#6E767D;" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z"/>
	</symbol>

	<symbol id="tcm-author-icon" viewBox="0 0 1020 1080">
		<polygon style="fill:#474F57" class="st0" points="44.5,882.9 251.4,1081 251.4,889.8 "/>
		<path style="fill:#6E767D" class="st1" d="M937.8,891.8H81.2c-44.3,0-80.6-36.3-80.6-80.6V82.7c0-44.3,36.3-80.6,80.6-80.6h856.6
			c44.3,0,80.6,36.3,80.6,80.6v728.5C1018.4,855.5,982.1,891.8,937.8,891.8z"/>
		<g>
			<path style="fill:#6E767D" class="st2" d="M732,688.3c-0.5,0.1-2.7,0.5-6.3,1.1c-142.4,25.4-168.6,29.8-171.6,30.1c-7,0.8-12.3,0.4-16-1.3
				c-2.4-1-3.6-2.3-4-2.8c0.2-1,1.4-3.3,2.2-4.7c0.7-1.4,1.6-3,2.3-4.6c4.9-11.1,1.5-22.4-8.9-29.5c-7.8-5.3-18.1-7.4-30.6-6.3
				c-7.5,0.6-138.9,22.6-211.1,34.7l-35.4,27.7c82.6-13.9,240.1-40.2,248.4-41c7.4-0.6,13.2,0.3,16.7,2.7c2,1.4,1.8,1.8,1.3,3.1
				c-0.4,0.9-1,2-1.6,3.2c-2.4,4.4-5.6,10.5-4.5,18c1.2,8.2,7.3,15.3,16.7,19.4c5.3,2.3,11.4,3.5,18.4,3.5c2.8,0,5.7-0.2,8.8-0.5
				c5.7-0.7,63.8-10.9,172.9-30.3c3.6-0.6,5.8-1,6.3-1.1c5.9-1,9.8-6.6,8.7-12.5C743.4,691.2,737.8,687.3,732,688.3L732,688.3z
				 M732,688.3"/>
			<path style="fill:#FFFFFF" class="st2" d="M349.8,583.9l-91.7,95.5c-10.1,10.5-17.2,23.5-20.6,37.7l130.2-102c40.8,18,73.3,23.7,98.3,23.7
				c43.8,0,64.2-17.7,64.2-17.7c-40.8-21.2-46.6-60.6-46.6-60.6c31.3,13.2,96.4,28.7,96.4,28.7c86.5-57.5,131.7-181.9,131.7-181.9
				c-9,2.5-17.5,3.5-25.6,3.5c-40.6,0-68.5-25.9-68.5-25.9l113-24.5c37.6-76.7,41.2-211.1,41.2-211.1L428.2,453.5
				C389.2,487.9,361.9,533.4,349.8,583.9L349.8,583.9z M349.8,583.9"/>
		</g>
	</symbol>

	<symbol id="tcm-bulk-action-arrow" viewBox="0 0 12 7">
		<path style="fill:#6E767D" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z"/>
	</symbol>


	</defs>
	</svg>
</div>	<script type="text/javascript">
		function atomicBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}
	</script>
	<script>
(function(){
  if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CK7I6KQM', 'placement:linuxhandbookcom');
  }
})();
</script><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: humble bundle new --><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="th9ti9h0awsouszwiwh5" data-user="447" data-env="production"></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Linux Hanbook Twitter --><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="iwykz9wzyrkbegqbkbub" data-user="447" data-env="production"></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Linux Handbook FullPage --><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="ju5dav87ido2kitcjom0" data-user="447" data-env="production"></script><!-- / OptinMonster -->		<script type="text/javascript">var th9ti9h0awsouszwiwh5_shortcode = true;var iwykz9wzyrkbegqbkbub_shortcode = true;var ju5dav87ido2kitcjom0_shortcode = true;</script>
		<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.6/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201933'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var socialsnap_script = {"ajaxurl":"https:\/\/linuxhandbook.com\/wp-admin\/admin-ajax.php","on_media_width":"250","on_media_height":"250","nonce":"345fab5ec0","post_id":"11326","click_tracking":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/socialsnap-pro/assets/js/socialsnap-1.1.5.4.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/assets/js/dismiss-1563945902.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy-pro/public/js/scripts.min-1.0.8.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/hoverIntent.min.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/superfish.min-1.7.10.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/superfish.args.min-3.0.3.js'></script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/skip-links.min-3.0.3.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"combine":[".nav-primary",".nav-social"],"others":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/themes/authority-pro/js/responsive-menus.min-1.2.0.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_dash_front = {"ajaxurl":"https:\/\/linuxhandbook.com\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/thrive-dashboard/js/dist/frontend.min-2.1.5.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":20,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["text-6","wp_coupons_widget-2"]}];
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min-5.1.9.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.6/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/backbone.min.js'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://linuxhandbook.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/js/frontend.min-1.2.4.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.6/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.6/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/linuxhandbook.com\/wp-admin\/admin-ajax.php","nonce":"f7446c4084","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/linuxhandbook.com\/wp-login.php?redirect_to=https%3A%2F%2Flinuxhandbook.com%2Fcheck-debian-version%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.6/_inc/build/carousel/jetpack-carousel.min.js'></script>

		<div id="ss-copy-popup" class="ss-popup-overlay">
			<div class="ss-popup">
				
				<div class="ss-popup-heading">
					<span>Copy link</span>
					<a href="#" id="ss-close-share-networks-modal" class="ss-close-modal" rel="nofollow"><i class="ss ss-close"></i></a>
				</div><!-- END .ss-popup-heading -->

				<div class="ss-popup-content">

					<div class="ss-copy-action">
						<input type="text" readonly="readonly" value="https://linuxhandbook.com/check-debian-version/" class="ss-copy-action-field" />
						<a href="#" class="ss-button" rel="nofollow">Copy<span class="ss-share-network-tooltip">Copied</span></a>
						<i class="ss ss-copy"></i>
					</div><!-- END .ss-copy-action -->

					<div class="ss-powered-by">Powered by <a href="https://socialsnap.com/?utm_source=WordPress&utm_medium=link&utm_campaign=inthewild" target="_blank" rel="nofollow noopener"><i class="ss ss-socialsnap"></i>Social Snap</a></div><!-- END .ss-powered-by -->
				</div><!-- END .ss-popup-content -->
			</div><!-- END .ss-popup -->
		</div><!-- END #ss-copy-popup -->

				<!-- Social Snap Share count cache indicator -->
		<script type="text/javascript">

			var SocialSnapURL 				= window.location.href;
			var SocialSnapShareCacheExpired = 0;
				
			if ( -1 !== SocialSnapURL.indexOf('?ss_cache_refresh') ) {

				SocialSnapShareCacheExpired = true;

			} else {

				var SocialSnapServerTimestamp 	= 1566130839;
				var SocialSnapBrowserTimestamp 	= Date.now();

				if ( ! SocialSnapBrowserTimestamp ) {
					SocialSnapBrowserTimestamp = new Date().getTime();
				}

				SocialSnapBrowserTimestamp = Math.floor( SocialSnapBrowserTimestamp / 1000 );

				SocialSnapShareCacheExpired = SocialSnapShareCacheExpired && ( SocialSnapBrowserTimestamp - SocialSnapServerTimestamp < 60 );
			}

		</script>
		<!-- Social Snap Share count cache indicator -->
		<script type='text/javascript' src='https://stats.wp.com/e-201933.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.6',blog:'144306046',post:'11326',tz:'0',srv:'linuxhandbook.com'} ]);
	_stq.push([ 'clickTrackerInit', '144306046', '11326' ]);
</script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://linuxhandbook.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: 'ad44ee4aac', slugs: {"th9ti9h0awsouszwiwh5":{"slug":"th9ti9h0awsouszwiwh5","mailpoet":false},"iwykz9wzyrkbegqbkbub":{"slug":"iwykz9wzyrkbegqbkbub","mailpoet":false},"ju5dav87ido2kitcjom0":{"slug":"ju5dav87ido2kitcjom0","mailpoet":false}} };</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":11326,"object_key":"post","object_type":"post","term_ids":[15,79]};</script>
		<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"db80538bbb","applicationID":"220210648","transactionName":"bwNaY0IEXBJTVEBdC1ZJeVREDF0PHURdWgNUAw==","queueTime":0,"applicationTime":940,"atts":"Q0RZFQoeTxw=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->